Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-04-2012, 12:46 PM   #1
Junior Member
rachcobb's Avatar

Join Date: Dec 2010
Location: Alabama
Photos: Gallery | Albums
Posts: 48
Grrr...autofocus on k-x not working

I have a Pentax k-X that I got on Dec 21, 2010. My husband dropped it a few weeks back, in the padded camera bag, but only about 2 foot from the ground. I got it out for Christmas and the autofocus won't work on any of my lens. I have the kit 18-55 and 50-200. I took it in to the local camera shop and they couldn't tell me what was wrong, how much to fix it...all I got was "We can send it off for a minimum of $200 and 10 weeks" I have reset all the factory settings but that's about all I know how to do, any help or ideas would be greatly appreciated.

01-04-2012, 01:01 PM   #2
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
QuoteOriginally posted by rachcobb Quote
all I got was "We can send it off for a minimum of $200 and 10 weeks"
And this would be why you should contact Pentax/CRIS about a repair, rather than a camera shop. Even shipping it in yourself, the turnaround time is generally about 3 weeks (although there have been delays with some models/problems cropping up recently). They will give you a quote before they start working on it, so the risk is shipping costs if you don't have them fix it.
01-04-2012, 01:02 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,140
Did it stop working right after the drop? Also, I hate to state the obvious, but is the AF switch in AF mode? You shouldn't see "MF" in the viewfinder, either.

If AF is enabled as per the switch, then it's probably broken and you'll have to send it in. Too bad it's out of warranty by a hair...but you should contact Pentax and try to get it serviced by their authorized repair center. Alternatively, you could probably pick up a new used one for around $300.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-04-2012, 01:20 PM   #4
Junior Member
rachcobb's Avatar

Join Date: Dec 2010
Location: Alabama
Photos: Gallery | Albums
Posts: 48
Original Poster
@ Philoslothical, I know I know but I am going out of town this weekend (tomorrow) and was really hoping it was a duh thing on my part so I could get it fixed in house and take my camera with me. My next step is to send it back to Pentax for repair.

@ Adam, I didn't use it again for a few weeks after he dropped it and the af no longer worked when I tried to use it for Christmas. I did double check the switch (it's not on MF) and it does have AF on the LCD and in the view finder.

01-04-2012, 01:28 PM   #5
Veteran Member
Philoslothical's Avatar

Join Date: May 2011
Posts: 1,723
I guess you've tried stuff like polishing the camera and lens contacts? You say it's an issue with both lenses, so the camera contacts sound more likely, but it wouldn't hurt to clean both. Just to rule it out.

As Adam suggests, you *might* be better off to pick up a new camera body than invest so much in a repair. I can't see it being less than the $200 the camera shop suggested if CRIS has to replace the AF module (but I could be wrong). Maybe it's time for an early upgrade?
01-04-2012, 02:27 PM   #6
Veteran Member
DaveHolmes's Avatar

Join Date: Jul 2010
Location: Yorkshire
Posts: 1,501
QuoteOriginally posted by rachcobb Quote
My husband dropped it a few weeks back,
If my girlfriend dropped an broke my K-x she'd be expecting to buy me a new one... If we were married she'd be buying me a K5...
01-04-2012, 03:06 PM   #7
Veteran Member




Join Date: Jan 2010
Location: Vancouver, BC
Posts: 1,421
Does the AF screw drive motor turn when the shutter button is pressed halfway to engage the AF? If the motor is silent then I would guess the motor is damaged, if the motor whines but don't AF, then the mechanical linkage between the lens and the body is suspect.
01-09-2012, 03:09 PM   #8
Junior Member
rachcobb's Avatar

Join Date: Dec 2010
Location: Alabama
Photos: Gallery | Albums
Posts: 48
Original Poster
@ Dave, he was looking at a K7 today but after reading the reviews I may need to redirect his shopping. We spent the weekend in Illinois and every old barn, gorgeous landscape, or funky tree/rock formation I saw, I would say "Wow, sure do wish I had MY camera..." Guilt is a wonderful thing.

@ excanonfd, it's silent...I've pretty much given up on fixing the one I have, I think it's time to up grade to, as Dave said, the K5 or K7

01-09-2012, 05:25 PM   #9
Veteran Member
DaveHolmes's Avatar

Join Date: Jul 2010
Location: Yorkshire
Posts: 1,501
QuoteOriginally posted by rachcobb Quote
@ Dave, he was looking at a K7 today but after reading the reviews I may need to redirect his shopping. We spent the weekend in Illinois and every old barn, gorgeous landscape, or funky tree/rock formation I saw, I would say "Wow, sure do wish I had MY camera..." Guilt is a wonderful thing.
I wouldn't put all your stock in reviews... I'd trade my K-x for a K7... K7 has somehow got a fairly bad rep... But it's a great camera... Except at high ISO the image quallity is superior to the K-x... How much High ISO (iso6400 etc) work do you do?
01-10-2012, 09:29 AM   #10
Junior Member
rachcobb's Avatar

Join Date: Dec 2010
Location: Alabama
Photos: Gallery | Albums
Posts: 48
Original Poster
I do little to no high ISO shots, most of them are playing around the house snapping shots of the kids and pets and just random "stuff" around here. I think for the money, I'll be looking for a k-x or k-7 body only. I've been checking ebay and my hubby is supposed to hit a few pawn shops for me. We'll see...all I know for sure is that'll I'll be sticking with Pentax
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-x, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 + 18-55mm Wr - Autofocus not working?? hknymz Pentax K-5 11 02-29-2012 04:50 AM
survey: batteries working/not working with the K-x noou Pentax DSLR Discussion 25 12-03-2009 02:43 PM
Help! Autofocus switch stuck on AF.S and will not autofocus! pauldiebel Pentax DSLR Discussion 3 09-19-2009 08:59 PM
For Sale - Sold: FS: Autofocus film cameras and autofocus lenses Not Registered Sold Items 15 03-17-2008 07:08 AM
In-Body autofocus vs In-Lens autofocus Gooshin Pentax DSLR Discussion 7 02-05-2008 11:10 AM



All times are GMT -7. The time now is 11:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top