Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-04-2012, 04:58 PM   #1
New Member




Join Date: Nov 2008
Location: New Brunswick
Posts: 5
Debug mode with K10D FW 1.31

Hi,
I'm having a problem with my K10D backfocussing and I wanted to fix it, however, my firmware is 1.31 and I cannot get into the debug menu. I have tried the whole, MODSET.TXT and then [OPEN_DEBUG_MENU] thing with leaving the door open and all of that jazz and it doesn't work. Any suggestions?

Thanks!

01-04-2012, 05:03 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,228
Might be patched in 1.31, but check this:
https://www.pentaxforums.com/forums/pentax-dslr-discussion/27040-k10d-firmwar...unleashed.html

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-05-2012, 12:11 PM   #3
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
Have you press "enter" at the end of the "text" so that it indicates it's on the next line.
It's a conmen mistake to forget that.
01-05-2012, 07:00 PM   #4
New Member




Join Date: Nov 2008
Location: New Brunswick
Posts: 5
Original Poster
I have tried hitting enter. I went straight from the 1.0 FW to the 1.31, I don't know if it matters that I didn't have the 1.30... If anyone has a copy of the 1.30, I would be willing to give that a try.
Thanks

01-05-2012, 07:06 PM   #5
New Member




Join Date: Nov 2008
Location: New Brunswick
Posts: 5
Original Poster
Also, Adam, I downloaded the program but it just gives a menu that comes up that is all question marks and I click on what would appear to be an "ok" or "continue" or something and it just closes. (maybe it's supposed to say "close", either way, I can't read anything)
01-06-2012, 06:44 AM   #6
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
QuoteOriginally posted by smurfy27 Quote
I have tried hitting enter. I went straight from the 1.0 FW to the 1.31, I don't know if it matters that I didn't have the 1.30... If anyone has a copy of the 1.30, I would be willing to give that a try.
Thanks
It overwrites the full firmware so you don't need to install 1.3 first since it doesn't add data but overwrites everything.
01-12-2012, 10:58 PM   #7
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,547
The debug programs I found would not work with 1.31 firmware on my K10. I was looking to revert the firmware to get the camera to screw focus a 50-135 with failed SDM. The ones I tried were written some time ago, and perhaps something in the bits and bytes of 1.31 confused them. I reverted the lens to the 55-300 instead. Bummer, but it works for me.
01-13-2012, 11:11 AM   #8
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
Might pktether maybe work?

01-24-2012, 10:13 AM   #9
Site Supporter
smigol's Avatar

Join Date: Sep 2008
Location: Menlo Park, CA
Photos: Albums
Posts: 406
pktether will work to enter and exit debug mode on these cameras.

Also, I've noticed that once you go to 1.31 firmware, you can't roll back to an earlier version.
That's why I've kept one of my K10D bodies old to be able to revert back in the event of another SDM failure.
01-24-2012, 12:57 PM   #10
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,547
QuoteOriginally posted by smigol Quote
pktether will work to enter and exit debug mode on these cameras.

Also, I've noticed that once you go to 1.31 firmware, you can't roll back to an earlier version.
That's why I've kept one of my K10D bodies old to be able to revert back in the event of another SDM failure.
That's why I had to unload my DA* 50-135. I went to 1.31, and it would not roll back. I tried several roll back sites, with no luck. I would still have the DA* instead of the DA L (which I find much better than expected) if I had been able to roll back. On the other hand, I might be able to fund another lens or two in the marketplace if I can sell my AFA 1.7X. I have not put it up yet, just in case, but ....
01-24-2012, 01:12 PM   #11
Pentaxian
builttospill's Avatar

Join Date: Jun 2009
Location: Utah, Idaho
Photos: Gallery
Posts: 1,675
QuoteOriginally posted by smigol Quote
pktether will work to enter and exit debug mode on these cameras.

Also, I've noticed that once you go to 1.31 firmware, you can't roll back to an earlier version.
That's why I've kept one of my K10D bodies old to be able to revert back in the event of another SDM failure.
Are you saying pktether allows full debug mode on 1.31? I've wanted to upgrade from 1.3 but haven't just in case I need it again.

QuoteOriginally posted by Canada_Rockies Quote
That's why I had to unload my DA* 50-135. I went to 1.31, and it would not roll back. I tried several roll back sites, with no luck. I would still have the DA* instead of the DA L (which I find much better than expected) if I had been able to roll back. On the other hand, I might be able to fund another lens or two in the marketplace if I can sell my AFA 1.7X. I have not put it up yet, just in case, but ....
That's really too bad. I'd love the 50-135 but just couldn't justify the risk, so instead saved up a little longer and went with the FA* 80-200.
01-24-2012, 01:57 PM   #12
Site Supporter
smigol's Avatar

Join Date: Sep 2008
Location: Menlo Park, CA
Photos: Albums
Posts: 406
QuoteOriginally posted by builttospill Quote
Are you saying pktether allows full debug mode on 1.31? I've wanted to upgrade from 1.3 but haven't just in case I need it again.
I've been able to turn debug on and off on my K10D that's on 1.31 with no problem with PK tether and with the russian software. I've never been able to get the flash card method to work.

FWIW, I've only had one lens fail with SDM, but that's another topic.
01-24-2012, 02:10 PM   #13
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,547
QuoteOriginally posted by smigol Quote
I've been able to turn debug on and off on my K10D that's on 1.31 with no problem with PK tether and with the russian software. I've never been able to get the flash card method to work.
The debug mode from 1.31 will not allow a roll back to a prior version. I needed to go back to 1.2 to disable SDM to be able to use the DA* 50-135 with AF. I was forced to using the AFA 1.7X to give me an 85-230 f/4.8 AF lens to have AF.
01-24-2012, 02:17 PM   #14
Site Supporter
smigol's Avatar

Join Date: Sep 2008
Location: Menlo Park, CA
Photos: Albums
Posts: 406
QuoteOriginally posted by Canada_Rockies Quote
The debug mode from 1.31 will not allow a roll back to a prior version. I needed to go back to 1.2 to disable SDM to be able to use the DA* 50-135 with AF. I was forced to using the AFA 1.7X to give me an 85-230 f/4.8 AF lens to have AF.
You are correct about not rolling back. Still, you can turn debug on and off while using FW 1.31. This allows AF adjustments, but not screw focus on SDM.
12-29-2013, 06:18 AM   #15
Junior Member




Join Date: Dec 2012
Posts: 26
Sorry for digging up this thread, but I got a K10D here. It had FW1.30 when it came and was in debug mode.
I wanted to get rid of the debug mode, so I figured I only need to update to the "normal" 1.31 and the debug mode will be gone.
But as you know, that is not the case. The firmware is updated, but how do I switch off the debug mode?
Thank you in advance.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
debug, debug mode, k10d, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D focus adjustment with debug mode cem.kumuk Pentax DSLR Discussion 12 01-16-2016 07:11 PM
AF Area Test in K10D Debug Mode mcjm78 Pentax DSLR Discussion 11 02-07-2011 09:57 AM
Anyone use K10D at debug mode? rosier19 Pentax DSLR Discussion 25 12-18-2010 07:34 PM
K10D Firmware 1.3 Debug Mode Unleashed! RiceHigh Pentax DSLR Discussion 148 10-01-2010 01:48 PM
K10D debug mode and 35 Limited macro treebeard Pentax DSLR Discussion 10 10-21-2009 08:47 PM



All times are GMT -7. The time now is 11:04 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top