Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-13-2012, 04:25 AM   #1
New Member




Join Date: Jul 2011
Posts: 10
is it broken?

I accidentally removed batteries when camera was on and now it won't turn on. Is it broken? (actually, i managed to turn it on 2 times, but after few shots camera stopped responding).

01-13-2012, 04:53 AM   #2
New Member
Stuart Windram's Avatar

Join Date: Jan 2012
Location: Johannesburg
Photos: Albums
Posts: 9
It could be that the software is corrupted. Try turning the camera on with the Menu button pressed, it should then show you the software version. If it doesn't do that, then I guess you'll have to send it in to Pentax.

I know this sounds obvious, but are the batteries in the camera correctly? It might also be that there is a bad contact between the battery/ies and the camera. Are they fully charged?

Hope you come right!
01-13-2012, 05:02 AM   #3
New Member




Join Date: Jul 2011
Posts: 10
Original Poster
nothing happends when i keep menu button pressed.

I bought my camera in Poland and I'm in UK right now. Do i have to send my camera to shop where i bought it, to polish distributor of pentax, or can i send it somewhere in uk? I still got valid warranty.
01-13-2012, 05:18 AM   #4
New Member
Stuart Windram's Avatar

Join Date: Jan 2012
Location: Johannesburg
Photos: Albums
Posts: 9
Can't really help you on that... I'm in South Africa - manufacturer's customer service is generally not the greatest in this part of the world.

My suggestion would be to find a local camera shop that deals with Pentax and ask them there.

01-13-2012, 10:30 AM   #5
Pentaxian
Marc Sabatella's Avatar

Join Date: Sep 2006
Location: Denver, CO
Photos: Gallery
Posts: 10,686
I've removed batteries with the camera on hundreds of times. That shouldn't in itself have caused any problems.
01-13-2012, 11:05 AM   #6
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Which camera? Which batteries (make / type)? I think it's coincidence and your batteries might have reached end-of-life. If it's a camera that uses AA, you can try alkalines (cheap) to check if it's the camera or the batteries; the camera should at least be able to start up and take a few shots.
01-13-2012, 11:15 AM   #7
Senior Member




Join Date: Dec 2009
Location: Münsterland
Posts: 124
If the cam was writing to SD-Card while removing the batteries data might be corrupted. Remove the Card and switch the cam on with new/loaded batteries.

-Linus-
01-13-2012, 11:20 AM   #8
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
Unless you removed the batteries while the firmware was updating, it shouldn't be a problem. Check the battery connections!

01-13-2012, 11:56 AM   #9
New Member




Join Date: Jul 2011
Posts: 10
Original Poster
It's pentax k-x. Batteries are fully charged (eneloops). How do i check battery connections?
01-13-2012, 12:22 PM   #10
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Look for corrosion on the battery connections.Think sd card is most likely problem.What battery type did you have the camera set for?
Jake
01-13-2012, 01:45 PM   #11
New Member




Join Date: Jul 2011
Posts: 10
Original Poster
"What battery type did you have the camera set for?"

what do you mean?


sd card is taken out. I don't see any corrosion.
01-13-2012, 10:17 PM   #12
Veteran Member




Join Date: Mar 2011
Location: Eastern Kentucky
Posts: 416
Check page 253 of your manual.
Jake
01-14-2012, 04:59 AM   #13
New Member




Join Date: Jul 2011
Posts: 10
Original Poster
auto-detect.
01-16-2012, 05:29 PM   #14
Veteran Member
DaveHolmes's Avatar

Join Date: Jul 2010
Location: Yorkshire
Posts: 1,501
Were you updating firmware at the point that you removed batteries?

There's deffinately no firmware listed on screen if you hold down 'menu' as you switch on?

In UK right? You need to get in contact with a 'Pentax Pro Centre'... My nearest one is the 'Bradford Camera Exchange'...The most well known one I can think of is 'SRS-Microsystems' both will more than likely refer you to the UK Pentax repair centre as you purchased in Poland...

Here's details of the UK Pentax Repair Centre:

Johnsons Photopia Ltd
Hempstalls Lane
Newcastle under Lyme
Staffordshire
ST5 0SW
Telephone: 01782 753350
E-mail: pentaxservice@jpss.co.uk

All this and more info is available at the UK Pentax website...
Hope you get it sorted mate...
01-20-2012, 05:21 AM   #15
New Member




Join Date: Jul 2011
Posts: 10
Original Poster
thanks.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken ME, want to take apart Capslock118 Pentax Film SLR Discussion 12 11-12-2010 05:19 AM
Lens is broken: broken mount nemo9439 Pentax SLR Lens Discussion 4 08-27-2010 09:52 AM
IS broken? sealisthenewbeaver Pentax DSLR Discussion 16 08-17-2010 07:00 AM
Broken dreams, broken camera brkl Post Your Photos! 3 03-10-2009 05:08 PM



All times are GMT -7. The time now is 10:46 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top