Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-30-2012, 09:50 PM   #1
Forum Member




Join Date: Apr 2011
Posts: 55
Bulb issues with K-x

Hi all!
Tonight I went outside to take some longer exposures with my K-x, and was happy with the results. However when I put the camera to bulb and kept the shutter open for a minute or so, when I let go of the Shutter, the camera’s buttons did not function the outer screen was not lit (the inner was) and I had to turn it off and then on to get it to work.
I thought perhaps it was the cold, but tried it again indoors after it warmed up, and it did the same thing.
The backlit display was off, only the inner display worked. The pop flash did pop up, but no other buttons or functions seemed to work, and going to other camera modes did not help either (I was in manual).
However unlike outside where I lost patience and shut the power, inside the house I waited and about a minute (or more) then the display came back on & showed the picture, and everything worked.
I am under warrantee and I’m curious to see if this is a design flaw or not, or whether I need to update the system. I did update about a half a year ago.
If anyone who has a K-x could please try this experiment I’d appreciate it.
Suggestions?
Thanks
Jake

01-30-2012, 10:37 PM   #2
Site Supporter
K57XR's Avatar

Join Date: Feb 2011
Location: Colorado, USA
Posts: 828
QuoteOriginally posted by FrumPilot Quote
Hi all!
Tonight I went outside to take some longer exposures with my K-x, and was happy with the results. However when I put the camera to bulb and kept the shutter open for a minute or so, when I let go of the Shutter, the camera’s buttons did not function the outer screen was not lit (the inner was) and I had to turn it off and then on to get it to work.
I thought perhaps it was the cold, but tried it again indoors after it warmed up, and it did the same thing.
The backlit display was off, only the inner display worked. The pop flash did pop up, but no other buttons or functions seemed to work, and going to other camera modes did not help either (I was in manual).
However unlike outside where I lost patience and shut the power, inside the house I waited and about a minute (or more) then the display came back on & showed the picture, and everything worked.
I am under warrantee and I’m curious to see if this is a design flaw or not, or whether I need to update the system. I did update about a half a year ago.
If anyone who has a K-x could please try this experiment I’d appreciate it.
Suggestions?
Thanks
Jake
It sounds like Dark Frame Subtraction. The K-x will perform DFS at exposures longer than 30 seconds and will not let you do anything during the process, this is normal.
Here's a short thread: https://www.pentaxforums.com/forums/pentax-beginners-corner-q/74669-dark-frame-subtraction.html
and this one: Dark-frame subtraction - Wikipedia, the free encyclopedia
Hope this helps!
01-30-2012, 10:46 PM   #3
krp
Veteran Member
krp's Avatar

Join Date: Oct 2010
Location: Illinois
Photos: Gallery
Posts: 470
That is the dark frame subtraction. Its purpose is to reduce noise and it makes you wait twice as long to use your camera again.
01-31-2012, 06:43 AM   #4
Forum Member




Join Date: Apr 2011
Posts: 55
Original Poster
Wow I never knew about that!
It seems that there's no way to turn that off. Thanks so much for your response.
Jake

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
bulb, buttons, camera, display, k-x, minute, pentax help, pop, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bulb mode Matheias Pentax K-r 7 11-09-2013 07:54 AM
Bulb mode MrK5 Pentax K-5 11 01-25-2012 05:52 AM
Has anyone tried the Bulb Mode on K-5 Pentax Lover Pentax DSLR Discussion 22 11-24-2010 07:27 PM
Bulb blower Russell-Evans Pentax Camera and Field Accessories 5 09-12-2010 08:38 AM
Bulb jolee1990 Troubleshooting and Beginner Help 5 04-01-2010 05:01 AM



All times are GMT -7. The time now is 09:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top