Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-08-2012, 07:30 PM   #1
Junior Member




Join Date: Dec 2011
Posts: 39
Help please with K100 D Super

Hi, I recently got my first Pentax, a k100 d super, just before Christmas.

I picked up a Pentax 50 f2 about a week ago, mounted, and used it.

Today I put the kit lens on, it wouldn't focus. I thought perhaps maybe I changed something in the menu, didn't have time to mess with it so threw the manual 50 back on.

Since coming home tonight I have..

Reset system in menu

Switched several times between af and mf on the body

Switched camera on and off several times

Put fresh batteries in camera

Tried 2 af lenses and the mf lens

Tried af c and af s

All to no avail!

Not sure what else to try?

Please help?

02-08-2012, 07:46 PM   #2
Junior Member




Join Date: Oct 2008
Location: United States
Photos: Albums
Posts: 36
try clean up the electrical contacts on both lenses and camera body?
02-08-2012, 08:02 PM   #3
Junior Member




Join Date: Dec 2011
Posts: 39
Original Poster
I will try that in the morning, Thank you! I hope it works!
02-08-2012, 08:09 PM   #4
Veteran Member




Join Date: Aug 2010
Location: Houston, Texas
Posts: 760
QuoteOriginally posted by alisonkim Quote
Today I put the kit lens on, it wouldn't focus.
Does it actually do anything at all? The other af lenses - do they respond appropriately? If they seem to be okay, do you have another Pentax af body anywhere that you can try the lens on that might actually indicate that the lens has developed an issue? You have tried a bunch of good contacts/settings/power kinds of things already.

Sorry to hear of the problems.

Glenn

02-08-2012, 08:11 PM   #5
Junior Member




Join Date: Dec 2011
Posts: 39
Original Poster
it wil shoot but the lenses dont even attempt to focus, I tried 2 different af lenses.

I have another body coming, maybe it will arrive tomorrow and I can try the 2 lenses on it and see if they respond.

At first when I would put the lens on and turn on the camera and half depress the the shutter, the lens would focus, just once, and then it wouldnt even budge or make a sound after that, now the lenses dont even focus when I turn the camera on and half depress.
02-08-2012, 09:04 PM   #6
Junior Member




Join Date: Dec 2011
Posts: 39
Original Poster
Update!

If I push ok on the back it focuses! Maybe I missed a setting somewhere! I am ok with pushing "ok" to focus! I was sick with worry!
02-08-2012, 10:25 PM   #7
Veteran Member




Join Date: Aug 2010
Location: Houston, Texas
Posts: 760
QuoteOriginally posted by alisonkim Quote
I am ok with pushing "ok" to focus!
That still seems a bit odd. Maybe another setting feature? I have had my k100dS for almost 3 years and do not ever recall needing to push "ok" to focus. But I'm glad that you at least found something that would get a response. Glenn
02-08-2012, 10:59 PM   #8
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
See page 126/129 of your manual. You can change the behavior of the OK button.

02-09-2012, 08:00 AM   #9
Junior Member




Join Date: Dec 2011
Posts: 39
Original Poster
Thank you! Guess I better go find a manual to download asap!
02-09-2012, 08:15 AM   #10
Pentaxian
bluestringer's Avatar

Join Date: Nov 2011
Location: Cotton fields of South Georgia
Photos: Gallery | Albums
Posts: 2,438
Manual can be found here;

Downloads & Literature - PENTAX Imaging USA
02-09-2012, 08:30 AM   #11
Junior Member




Join Date: Dec 2011
Posts: 39
Original Poster
You all are great! A big HUGE thank you to everyone for all the help
02-13-2012, 07:00 PM   #12
Senior Member
average-guy's Avatar

Join Date: Dec 2010
Location: Idaho
Posts: 102
I'd check the section of the manual that covers "custom functions". Whenever I get a used (new to me) camera body I go through and reset all custom functions to my preference.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, camera, k100, lens, menu, mf, pentax, pentax help, times
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k100 d super won't go into auto flash mode tdmsu Troubleshooting and Beginner Help 2 11-04-2011 05:17 AM
K100 D Super T Edwards Pentax DSLR Discussion 3 03-06-2010 10:42 AM
Pentax K100 Super flash question pentaxable Troubleshooting and Beginner Help 5 11-23-2009 02:09 PM
Best short FAST zoom lens for K100 Super audio_mad Pentax SLR Lens Discussion 3 03-02-2009 12:24 PM
k200D vs. K100 Super D LSC Pentax DSLR Discussion 2 07-27-2008 09:23 AM



All times are GMT -7. The time now is 10:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top