Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-13-2012, 02:35 PM   #1
New Member




Join Date: Feb 2012
Posts: 1
Pentax Program Plus - Shutter won't work

It was working fine for the longest time. Until yesterday when I was working on a project for class. I took a picture. Hit the advance lever and went to take another picture and it wouldn't work. I looked it over, tried advancing the lever again, nothing. Eventually just pushed some buttons, changed settings and what have you... still nothing. I brought it into class today, and my professor hit the button and it worked fine. He sent me out and about with it to get some pics so I could develop them. I took about 8 pictures, it did the same thing. I brought it back in, he pushed some buttons. Nothing. It randomly worked again though. So I went back outside. Took one pic, and it stopped working. I pushed some buttons, nothing. Then it worked again once. Then stopped working. Now we just can't get it to work at all. I've read through the manual and all. Nada. No idea what to do.

02-13-2012, 02:39 PM   #2
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
The battery could be (almost) dead and likely needs to be replaced.
02-13-2012, 02:39 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,140
Does it work fine in 1/125s mode?

If so, then it's your battery. Put in a new one

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-13-2012, 07:17 PM   #4
Loyal Site Supporter
foto guy's Avatar

Join Date: Apr 2008
Location: Vernon, Connecticut
Photos: Gallery | Albums
Posts: 276
Is that one of those cameras where the advance lever locks the shutter when it's all the way in? If not, then hopefully it's the batteries. Hope it's not flaky electronics.

02-15-2012, 07:56 PM   #5
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
Hopefully it is the battery but my Ricoh XR2s has a similar issue and it was first brought about by using a real heavy zoom and the body tripod screw. Many cameras of this era had intermittent issues due to flexing of the internal structure when heavy lenses were used
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
buttons, class, lever, pentax help, picture
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why won't my lightmeter on my Ashai Pentax 6x7 work? yoav Pentax Medium Format 4 10-21-2011 05:35 PM
Does Pentax SR really work @ 600mm and very low shutter speeds? Marc Langille Pentax DSLR Discussion 18 06-11-2011 03:59 AM
K10D Rear E-dial Won't Work NiftyFifty Troubleshooting and Beginner Help 2 07-21-2010 03:26 AM
Why won't Pentax flash PTTL work? jshram Flashes, Lighting, and Studio 61 04-02-2010 08:55 AM
Light Meter won't work on my Asahi Pentax KX AnthonyG Troubleshooting and Beginner Help 3 12-04-2009 03:14 PM



All times are GMT -7. The time now is 05:02 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top