Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-29-2012, 07:36 PM   #1
New Member




Join Date: Feb 2012
Posts: 4
K2000 Battery Issue

I am new to this forum. I shoot with a K2000 and have encountered a problem where after every three pictures the camera locks up. I must open the battery door to disconnect power, close the door and the camera will shoot three more pictures before repeating the process. Has anyone else experienced this issue? Thanks.

02-29-2012, 07:40 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
Have you been able to reproduce this with two different SD cards?
02-29-2012, 09:17 PM   #3
New Member




Join Date: Feb 2012
Posts: 4
Original Poster
Three cards, actually, and all different manufacturers.
02-29-2012, 10:31 PM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,958
Sounds like it might be a hardware problem then, unfortunately. Have you upgraded the firmware to the latest version?


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

03-01-2012, 04:43 PM   #5
Veteran Member




Join Date: Dec 2010
Location: Central Kentucky
Photos: Gallery | Albums
Posts: 1,415
What batteries are you using? Any error messages?

Cheap nimh can cause all kinds of funky behavior.
03-01-2012, 05:09 PM   #6
Pentaxian




Join Date: Mar 2010
Location: Frankfurt am Main
Posts: 1,045
Sounds as if the voltage provided to the working parts of the camera is at the lower limit. This can be an issue with either the NiMH or the voltage regulation circuit in the camera. Cheapest way to test would to try it with newly fabricated and unused Eneloops.

Edit: Another possibility (unfortunately not so easily to be varified) would that some component of the camera is, while switched on, drawing a very high current

Last edited by RKKS08; 03-01-2012 at 05:14 PM.
03-01-2012, 07:31 PM   #7
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
Don't dump the K2000 until you've tried Eneloops (or Duraloops).
03-02-2012, 05:07 PM   #8
Veteran Member




Join Date: Dec 2010
Location: Central Kentucky
Photos: Gallery | Albums
Posts: 1,415
Current firmware is v 1.11 on this site it say 1.10, I have yet to upgrade.

As for the battery issue, if that is the issue I refer you to this thread: https://www.pentaxforums.com/forums/pentax-k-r-forum/177240-aa-energizer-lithium-problems.html

03-02-2012, 08:00 PM   #9
New Member




Join Date: Feb 2012
Posts: 4
Original Poster
I have updated the firmware and ordered some eneloops. I'll post the results. Thanks for all the help.
03-10-2012, 11:44 AM   #10
New Member




Join Date: Feb 2012
Posts: 4
Original Poster
Installed the eneloops after the firmware update. So far so good. Hopefully this solves the problem. Thanks for the help!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, door, issue, k2000, pentax help, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Km: Issue with Battery connections? Pandora77 Pentax DSLR Discussion 5 05-28-2011 07:57 PM
Pentax KM battery issue J.Snider Pentax DSLR Discussion 12 05-09-2011 07:03 AM
K-7 Battery Life Issue Chaos_Realm Pentax DSLR Discussion 6 03-26-2011 12:00 AM
Pentax K5 Battery Issue blitzping Pentax K-5 3 02-18-2011 10:46 PM
K-x Battery Issue gkamieneski Pentax DSLR Discussion 6 12-17-2010 02:51 PM



All times are GMT -7. The time now is 02:39 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top