Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-10-2012, 07:09 PM   #1
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,198
Communication prob with K-x and Metz48

Just a question since I don't know if it's normal P-TTL flash behavior or if it's a problem with the camera body or the flash. When I mount the Metz48 on my K-x the LCD should display the corresponding distance and the auto zoom head should work automatically as you zoom the lens in and out right?

Here's the problem: When I mount the Metz48, sometimes the pTTL function stays, displaying the guide number and zoom to the right, then go blank suddenly, though the label on the top still says it's on p-TTL. I think it's a communication problem between my K-x and the flash, but how should it be solved? I've cleaned all the contacts on both flash and body but the problem persists. Could batteries also be included as contributor to the issue?

Also, I noticed another odd behavior: Sometimes when the p-TTL does hold, I try to swivel the flash head... and bam, it goes blank again. Or sometimes I mount it and it displays well, when I turn it off and on again (without removing the flash) the problem returns. So is it the camera body, or the flash, or both?

05-10-2012, 08:14 PM   #2
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
The second "problem" is a feature, once you bounce the flash the flash has no way ot telling you how far it can throw light. So it only gives a distance when the head it aimed straight ahead.

It's not clear to me if the first situation is actually a problem, or just another "feature" where it only displays setting for a short period.
05-10-2012, 08:30 PM   #3
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,198
Original Poster
QuoteOriginally posted by twitch Quote
The second "problem" is a feature, once you bounce the flash the flash has no way ot telling you how far it can throw light. So it only gives a distance when the head it aimed straight ahead.

It's not clear to me if the first situation is actually a problem, or just another "feature" where it only displays setting for a short period.
I see, thanks! The first situation is what confuses me. Sometimes even in bounce mode, the "feature" works - but when I turn it off and on again, it stops working.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
behavior, body, camera, communication, flash, k-x, metz48, p-ttl, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
CS4 jpg File Size prob westmill Digital Processing, Software, and Printing 8 01-26-2012 09:29 AM
[flash]prob stupid question but.... jupzchris Pentax DSLR Discussion 6 04-21-2010 11:00 AM
hi everybody, prob with a lens donquichoque13 Welcomes and Introductions 7 09-16-2009 09:33 PM
Foggy Communication Damn Brit Post Your Photos! 14 07-26-2009 01:21 AM



All times are GMT -7. The time now is 09:33 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top