Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-12-2012, 08:25 AM   #1
Inactive Account




Join Date: May 2012
Location: markham
Photos: Gallery
Posts: 2
Help with 2x teleconverter

I have a 2 x sunaction teleconverter from my old k1000.

I have also have a 500mm f8 "base ball bat" lens

The lens works on k5 but when I put on the 2x TC I get the 2X zoom but my shutter won't work

I have tried Shutter priority , Manual and bulb.
I have tried insulating the the contacts on the k5 body too

Any suggestions ?

05-12-2012, 08:45 AM   #2
Veteran Member
demp10's Avatar

Join Date: Jun 2011
Location: Atlanta
Photos: Albums
Posts: 602
Most likely your TC has plastic or paint that is not conductive on its mount. You need to short the contacts, and not to insulate them. You camera probably thinks that there is no lens attached. An easy test is to cover the contacts on the body with aluminum foil and then mount the lens. If that works, then definitely it is a conductivity issues. Try to remove the paint on the TC mount with fine sandpaper or steel wool.
05-12-2012, 09:24 AM   #3
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,517
David, if you're using the lens with the camera set on AF, turn off the AF - should work fine after that. Also, make sure you have the option set in the custom menu (I don't have a K5 so I'm assuming the menu set-up is simular to my K20D) to allow using "using aperture ring".
05-12-2012, 02:45 PM   #4
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
The problem is most likely that you don't have USING APERTURE RING permitted. I'm not sure with the K5, but my K20D doesn't care whether or not a lens is present when I want to trip the shutter. Scraping paint from the mount allows CIF to function. I just use a file to remove paint as needed.

05-12-2012, 08:28 PM   #5
Inactive Account




Join Date: May 2012
Location: markham
Photos: Gallery
Posts: 2
Original Poster
Solved

Thanks everyone.

Setting the the camera to allow the apature ring is a much better solution!

I examined the differences between the TC and the T mount converter and discovered a lever sticking out that would reach into the body.

I now realize that was for the auto apature. I was in the process of taking apart the TC to remove the lever and decided to check in......



Thank-you thank-you very much.
My next Moon shot will be better
500mm manual f8 + the 2x TC + the crop factor should give me about 1600 mm for my next attempt
Good thing the moon is reflected sunlight because I'm going to lose alot of light with this glass. But heck it was cheap !
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
2x, k5, lens, pentax help, shutter, teleconverter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
teleconverter nuk20d Ask B&H Photo! 2 08-03-2010 01:01 AM
What happens when I use a teleconverter? dmoon911 Pentax SLR Lens Discussion 9 07-08-2010 08:34 AM
Teleconverter(s) ? Caddis Pentax SLR Lens Discussion 6 05-18-2010 05:16 PM
For Sale - Sold: Tamron 1.4x Pz-AF MC4 Teleconverter & Quantaray 2x Teleconverter DaveInPA Sold Items 15 09-24-2009 06:28 AM



All times are GMT -7. The time now is 06:09 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top