Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-12-2012, 04:54 AM   #1
New Member




Join Date: Aug 2011
Location: Birmingham UK
Posts: 15
Every Button pressed sounds like a photo has been taken

I have had a K5 for over a year now. Love it.
BUT.....over the last few weeks it has started to give me a problem. It doesn't seem to matter which button I press or whether I try and take a photo I get a sound as if I had taken a photo. But a photo is not actually taken. This happens regardless of which lens I use and also happens with no lens attached. So it cannot be due to dirty contacts on the lens.

The problem is intermittent (inevitably) and so far I have not been able to establish what sets this problem off. I have tried with a fully charged battery or a partially discharged battery - doesn't seem to matter. Also taking the battery out and then reinserting it. Sometimes this stops the problem for a while. Also switching the camera off can help but not always.

Am in Spain at present, could heat affect it? But I'm fairly sure this problem has happened in England with no high temperatures.

Hope I've clearly explained the problem. Any help or advice would be appreciated.

Cheers....John

06-12-2012, 05:32 AM   #2
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Do a search for 'mirror flop'. If I recall correctly, a PCB needs to be replaced. Warranty affair (and EU law gives user protection for 2 years if I'm not mistaken, even if the warranty has ended).
06-12-2012, 06:07 AM   #3
Veteran Member
darrenleow's Avatar

Join Date: Feb 2009
Location: Chicago
Photos: Gallery
Posts: 541
Something like this?

I sent mine in to Pentax couple of times and eventually they got it fixed after quite a long wait.. Not sure if it was due to parts or them trying different fixes, but it eventually worked properly again

Here's what they fixed according to the report:
REPLACED APERTURE/SHUTTER F.P.C.
REPLACED TIMING CAM GEARS
ADJUSTED TO MANUFACTURERS SPECIFICATIONS
GENERAL CHECK AND CLEAN
RESET ALL
06-14-2012, 01:37 PM   #4
New Member




Join Date: Aug 2011
Location: Birmingham UK
Posts: 15
Original Poster
Yes - exactly like that Darren. I can often take a couple of shots then it goes into 'Mirror Flop' mode. Fortunately it's still under warranty (not over a year as I first thought) and I'll sort this out when I'm home from holiday in Spain. I'll make a note of what was fixed on your camera!

Thanks and thanks to sterretje. So frustrating - I still have my K7 - wish I'd bought it with for backup! Hindsight is wonderful.

John

12-02-2012, 01:41 PM   #5
New Member




Join Date: Dec 2012
Posts: 5
My K2000 just did this yesterday. Non-stop. No taking pics in between. I have 2 sets of rechargeable batteries that I use. I rotated out to a different set and all seems ok right now.
12-03-2012, 10:09 PM   #6
Junior Member




Join Date: Feb 2011
Location: California
Photos: Gallery | Albums
Posts: 30
I've written of this before, but paraphrasing. My experence, K-r mirror flopped. Things that seemed related, 1) low battery charge. Recharged battery and problem was reduced. 2) type of lens installed, Installed a lens with a metal base instead of the DAL it came with and problem went away. 3) Lens mount and lens contacts dirty. After cleaning problem ended, even when using the DAL kit lens.

I haven't been able to investigate further because after cleaning lens mount contacts the problem has not reoccurred. Low battery charge definitely made the problem worse.

Results on K-5 may be different. Some will say I'm wrong and I say to them PUTTH! Worked for me, that's all I know.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, button, help, lens, matter, pentax help, photo
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Half Pressed Snap - Keep Snapping crusniq Pentax K-r 3 05-22-2012 06:09 AM
Green button or +/- button for meter? kidblue Pentax SLR Lens Discussion 15 07-29-2011 07:10 PM
Sounds like an old joke seacapt General Talk 18 06-29-2010 06:09 AM
Well I pressed the button and bought an EOS 7D Big G Non-Pentax Cameras: Canon, Nikon, etc. 48 04-01-2010 01:51 PM
exposure changes when shutter pressed? adwb Pentax DSLR Discussion 4 02-26-2010 06:15 PM



All times are GMT -7. The time now is 05:15 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top