Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-01-2012, 02:35 PM   #1
New Member




Join Date: Jun 2012
Location: SLC, UT
Posts: 7
[SOLVED]K-5 Weird Behavior in 'M'

When I'm using the camera in M mode (most of the time) most of the time it behaves like I'm in an auto mode. After taking a picture it changes my aperture/shutter settings. Also, it restricts adjustments I try to make sometimes. Two days ago I was taking pictures while out on a drive and it kept changing things on its own to the point that to take 5 pictures and try and tweak just exposure time between them took a really long time.

Sometimes it restricts aperture illogically as well. I was trying for a wide-angle shot at 18mm with the kit lens and it wouldn't let me step any larger than f/13 until after I took a picture and it did the annoying self-adjust and put itself at f/5.6, after which point I was able to adjust it again.

I have combed the menus and I'm pulling my hair out. Any help would be appreciated. If it's just a setting, that would be awesome.

The camera is using firmware 1.13


Last edited by deadwood83; 07-01-2012 at 04:04 PM.
07-01-2012, 02:38 PM   #2
Veteran Member
manacho2005's Avatar

Join Date: Oct 2011
Location: Red Oak, TX
Photos: Gallery | Albums
Posts: 462
See if Auto EV compensation is on
07-01-2012, 03:40 PM   #3
New Member




Join Date: Jun 2012
Location: SLC, UT
Posts: 7
Original Poster
Auto EV Compensation is set to 1 (Off)
07-01-2012, 03:48 PM   #4
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
Beats me, but some people have reported resetting to factory defaults sometimes fixes weirdness that can't be figured out. Easier to do if you don't have a ton of custom settings already...

07-01-2012, 04:04 PM - 1 Like   #5
New Member




Join Date: Jun 2012
Location: SLC, UT
Posts: 7
Original Poster
Not sure if it gets more embarrassing than this. I had the camera in bracketing mode with one touch bracketing set to off. I was just never holding the shutter down long enough to make it bracket.

Hahahahaha. Wow, that was both fantastic and horrible.
07-01-2012, 04:13 PM   #6
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
lol you never know, you might have helped someone with the same issue
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, mode, pentax help, photography, picture, pictures, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Helios with weird aperture behavior [solved] MSL Pentax SLR Lens Discussion 7 06-21-2012 01:59 PM
flash weird behavior Lucky-Luc Flashes, Lighting, and Studio 0 02-16-2012 05:50 AM
K-r strange behavior? kostadinov Pentax K-r 3 02-19-2011 07:53 AM
K-5: behavior with flash in Av Mirek Pentax K-5 4 12-07-2010 06:12 AM
Advice on weird Takumar behavior germar Pentax SLR Lens Discussion 1 10-26-2008 08:34 PM



All times are GMT -7. The time now is 08:32 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top