Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-03-2012, 03:38 PM   #1
Junior Member
PenPen's Avatar

Join Date: Apr 2012
Location: Michigan
Posts: 28
Help w/new lens

Hi.I purchased a Sears 135mm F/2.8(private party) prime macro lens for my K-m. I set the camera on M and the aperture ring to A. The lens just shuts down the camera and the blinking on the screen of "f/stop" is all that I can get out of it.I know the lens can be used because it can and has been used on k-5's. Please tell me how I can fix the problem?
BTW:The first time I connected the lens to my camera,it got stuck.Really stuck,but I finagled around with it and got it loose.My other Sigma and Pentax lenses are still working fine,so I don't think I killed my camera!
Thank you to all who reply!
PenPen

07-03-2012, 04:27 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
Try reading this

I think you need to turn on "use aperture ring" in the menu. I do not know where in the menu that is on the k-m, though. I assume that lens is either a 'k' or 'm' series.
07-03-2012, 04:59 PM   #3
Site Supporter




Join Date: Sep 2009
Location: Langley, BC
Photos: Gallery
Posts: 528
QuoteOriginally posted by PenPen Quote
BTW:The first time I connected the lens to my camera,it got stuck.Really stuck,but I finagled around with it and got it loose.My other Sigma and Pentax lenses are still working fine,so I don't think I killed my camera!
Thank you to all who reply!
PenPen
Google "ricoh pin" - that may be the issue. Do not mount the lens again until you check to see if it has this pin on the mount. If it does, it will get stuck in the AF screw drive.

EDIT: try these:

http://www.theatreofnoise.com/2008/05/ricoh-lenses-on-pentax-cameras-ricoh.html

http://www.techtheman.com/2009/12/ricoh-pin-and-pentax-kr-mount.html
07-03-2012, 05:20 PM   #4
Junior Member
PenPen's Avatar

Join Date: Apr 2012
Location: Michigan
Posts: 28
Original Poster
PenPen says:

Thank you !! Set the A ring to permitted,and now the lens and camera work just great!
Thank you so much!!!


07-03-2012, 05:37 PM   #5
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,772
QuoteOriginally posted by PenPen Quote
Set the A ring to permitted,and now the lens and camera work just great!
Can you verify that the lens has an 'A' position on the aperture ring? If it does and you have it set to 'A' then you should be able to change aperture using the camera dial assuming everything is working correctly. If it does not have an 'A' position then you have what is commonly called an 'M' or 'K' series lens with no electrical contacts.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keep K-x buy premium lens, get K-r and get good lens, get the K-7 w/ lens or K-5? crossover37 Pentax DSLR Discussion 19 02-06-2011 10:38 PM



All times are GMT -7. The time now is 06:08 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top