Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-16-2012, 12:57 AM   #1
New Member




Join Date: Jul 2012
Posts: 1
K-x crashing

I have a 3 month old Pentax K-x camera it has recently started to continually sound like the shutter is clicking and wont function, if I press LV button it will do this for around 30 sec to a min the camera wont function at all when this is going on I have tried taking off the lens, turning it on and off, switching between modes. It will eventually fix its self and then shoot photos all day without missing a beat. Can anyone suggest what may be the problem?

07-18-2012, 09:04 AM   #2
New Member




Join Date: Aug 2011
Posts: 20
I'm not sure what the issue may be. Have you checked to make sure your firmware is up to date? I doubt it's a firmware update, but at least worth a try.
07-18-2012, 09:10 AM   #3
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
Did you get it used? If you just bought it from a shop and it is under warranty, take it back or send it in.

That sounds like an electrical problem similar to K-5 mirror flop.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, function, k-x, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Landscape 3 second exposure of waves crashing into the rocks off the coast of Monterey, CA DominicDom Post Your Photos! 3 07-09-2012 08:05 PM
Crashing Reid's party jeffkrol General Talk 2 11-02-2010 12:04 PM
Nature Crashing Waves Timtast1c Post Your Photos! 5 12-01-2009 09:28 AM
People Crashing a Wedding goddo31 Post Your Photos! 2 10-25-2009 06:54 AM
Rocky Beach/ Crashing Waves dermc Post Your Photos! 6 07-02-2008 09:54 AM



All times are GMT -7. The time now is 08:19 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top