Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-24-2012, 07:54 AM   #1
Site Supporter
Site Supporter




Join Date: Jul 2012
Posts: 4
K10d no autofocus with Sigma 70-300 DG Macro zoom

Hi, I'm looking for help or suggestions re a strange problem with a pal's K10d and a Sigma 70-300mm DG Macro.

A week ago the auto-focus stopped working, the camera treating the lens as a manual. However the auto-focus continues to work with my friend's Pentax18-55mm kit lens. The K10d's auto-focus also works with my Pentax 55-300mm, Tamron AF 70-300mm, and Sigma 28-105mm, and also my Pentax 100mm macro. Additionally, there are no problems with the autofocus on the Sigma 70-300mm DG Macro when its mounted onto my K20d.

So, since I think we have eliminated any physical problems with contacts/A settings etc on both the lens and the camera, I'm left assuming there is some clitch in the K10d's software - we've tried resetting the camera to default but to no avail. When you mount the Sigma 70-300mm DG Macro on to the K10d and switch the camera on, the lcd viewer panel still shows the blue screen for manual lenses (allowing you to set the focal length for the 'manual focus' lens), so resetting hasn't helped.

I'm stumped, happy to receive any suggestions ?

CliveG

07-24-2012, 10:25 AM   #2
Loyal Site Supporter
Loyal Site Supporter
eddie1960's Avatar

Join Date: Aug 2010
Location: Toronto
Photos: Gallery | Albums
Posts: 12,273
try cleaning the contacts on both and make sure it's locking in place correctly
90% of the time the cleaning solves this type of issue (where it works on some but not all cameras)
some people rub them with an eraser, I would start with a micro fiber cloth myself, and maybe a little contact cleaner on it
07-24-2012, 03:28 PM   #3
Site Supporter
Site Supporter




Join Date: Jul 2012
Posts: 4
Original Poster
Thanks very much for the suggestion. Your advice has been followed but unfortunately the problem remains. Additionally the camera was updated to the latest firmware for the K10d this afternoon, and now the autofocus for Pentax 18-55mm kit zoom lens is not been recognised!
07-26-2012, 07:20 AM   #4
Pentaxian
reeftool's Avatar

Join Date: Dec 2007
Location: Upstate New York
Photos: Gallery | Albums
Posts: 8,173
Strange problem but I doubt it's a software issue. I own one of those lenses and have used it since the day I bought my K10D. It has worked with every firmware version. Since the lens works on a different camera, I would guess that something just isn't right with the lens contacts on the camera body now that another lens is acting up. The contacts are spring loaded. Is one of them sticky or pushed in and not moving freely?

07-26-2012, 08:57 AM   #5
Loyal Site Supporter
Loyal Site Supporter
eddie1960's Avatar

Join Date: Aug 2010
Location: Toronto
Photos: Gallery | Albums
Posts: 12,273
contacts are the likely culprit
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
70-300mm, auto-focus, camera, dg, k10d, lens, macro, pentax help, sigma, sigma 70-300 dg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: *Pentax* Sigma Zoom Telephoto 70-300mm f/4-5.6 APO DG Macro Autofocus jgredline Sold Items 1 03-13-2012 04:14 PM
[SOLD]Pentax K mount, Sigma 70-300 f 4/5.6 macro autofocus with aperture ring and A Markbrumbaugh Sold Items 4 02-28-2012 01:17 PM
Sigma 70-300 1:4-5.6 DL Macro vs Sigma 70-300mm F4-5.6 APO DG MACRO (Comparo) adr1an Pentax SLR Lens Discussion 7 05-08-2011 06:46 PM
For Sale - Sold: Sigma Autofocus Zoom: 28-80mm f3.5-5.6 II Macro Aspherical P/KA CHEAP! (Worldw cheekygeek Sold Items 2 08-03-2010 01:33 PM
leopard w/ k10d & sigma 70-300 apo dg macro Evolution Post Your Photos! 7 02-12-2007 10:54 AM



All times are GMT -7. The time now is 12:29 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top