Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-01-2012, 04:35 AM   #1
Forum Member




Join Date: Sep 2010
Location: Sydney
Photos: Albums
Posts: 83
update from 1st ds to K7 in P mode pictures washed out

hello, so been a while since I've picked up a camera until I scored a Pentax K7, now from my 1st DS it's way more advanced, but use it in much the same way.

I generally shoot in P mode on my 1st DS and never had any problems, Now on my K7 I find that the pictures are all but washed out, no real color , I've changed the wb with no effect, in frustration I changed the dial to green mode and the pictures are coming out wonderful, plenty of color I just can't seem to get the same result in any mode other than green mode..

I know this is a huge newbie question but I just don't have a clue what I'm doing wrong... I've looked at all the settings and can't pin point where I'm going wrong...

I've had it about a week and did a few sunsets, at first I thought this is crap, until i flipped onto Green mode, then it was awesome, but I like to create my own shots with a hint of to much light or not enough, experiment...

Any help would be much appreciated.... why are my shots being washed out, as if there was no color at all.... just shades, very frustrating....

08-01-2012, 04:48 AM   #2
Pentaxian
audiobomber's Avatar

Join Date: May 2008
Location: Sudbury, Ontario
Photos: Albums
Posts: 6,683
Go into the menu and select Reset All (should be the last entry, but I don't have a K-7 to check). That will probably resolve your issue. You are likely shooting in Natural image tone, which is intended for users who want to adjust colour, contrast, sharpness and saturation on their own. Resetting will bring the camera back to Bright image tone.

Do you have a manual? It sounds like it would be beneficial for you to study it. If you're going to shoot jpegs, you should learn how the in-camera processing works.
08-01-2012, 04:59 AM   #3
Forum Member




Join Date: Sep 2010
Location: Sydney
Photos: Albums
Posts: 83
Original Poster
Thanks, shall have a look, no manual as of yet, I'll download one asap....
08-01-2012, 11:27 AM   #4
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,861
I have both cameras so I've been trying to see what the problem is. I can't duplicate it yet but here are some ideas:

The metering is different, with the K-7's 77 segment vs. 16 segment on the DS. They'll interpret some scenes differently.

Base ISO is 100 on the K-7 and 200 on the DS, which I forgot about. It shouldn't matter under most conditions but might combine with other differences.

The K-7 program is both different and adjustable. It's different because it's thinking about SR, the different meter, and other characteristics of the camera. You can also set it to emphasize different behaviors. I just looked at mine and it was set on Sports - I have no idea how it got there. The reset should fix that.

The DS doesn't do anything in P mode when you turn the e-dial, unless you hold down the exposure compensation button. The K-7 will shift into a hyper-program mode. I think that might even depend on how the e-dial behavoir is set up. On mine, turning the rear dial shifts into Av Hyperprogram, which shows on the rear display. The front dial shifts into Tv Hyperprogram.

Based on my brief experiment, the reset is a good idea. You could track down the exact setting that's causing the difference between P and Green modes by taking a photo in each one, then comparing the camera setting data between them. The manual has a list of all the settings that Green mode controls directly so you can't mess them up. It has to be one of those.

08-01-2012, 12:26 PM   #5
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,903
You should also post an offending image with exif intact.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, color, ds, k7, mode, pentax help, photography, pictures, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
pictures have blue tint in every mode but green mode pearsaab Pentax K-5 7 01-23-2012 06:13 AM
My 1st few shots with the K5 and my 1st attempt at shooting RAW aaronius Pentax K-5 5 12-04-2010 12:35 AM
Three pictures from Norway 1st of March Larsenio Post Your Photos! 8 03-02-2009 04:29 PM
1st time posting pictures... with my 35-70mm kjfaust Post Your Photos! 11 07-10-2008 02:06 PM
FA 50 f/1.4 arrived, 1st 5 pictures hinman Pentax SLR Lens Discussion 3 08-10-2007 09:12 PM



All times are GMT -7. The time now is 01:37 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top