Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-15-2012, 10:51 AM   #1
Veteran Member
ChooseAName's Avatar

Join Date: Aug 2009
Location: Southeast USA
Photos: Gallery | Albums
Posts: 390
Metz 48 refuses to fire at dialed power with K-x

I have a Metz 48 flash, K200D, K-x, and mostly manual lenses. When I have the Metz on the K200D with a manual lens, the flash will fire at the power which I've dialed in. When I put it on the K-x (moving the lens from the K200D as well), the flash fires at what looks like the weakest power. Is there some setting on the K-x which is preventing me from setting flash power?

Another data point is that when I have a modern lens (DA35/2.4) on the K-x with flash, the flash will fire at intended power.

I have cleaned the hot shoe contacts on the K-x and that didn't do anything. Both bodies were in M mode the whole time.

This does not seem like normal behavior to me. Is it normal for K-x's? Or did I just get a bad copy? I've also posted recently about what I think/thought might be viewfinder/focus issues: https://www.pentaxforums.com/forums/general-technical-troubleshooting/198991-...sus-k200d.html

EDIT: I did not change any flash settings, the flash is on P, TTL, HSS mode. I don't think it's an issue of flash battery charge level, since the flash indicates that it's ready to fire. Also, I uploaded two images from the K-x, with EXIF intact: one with manual lens (M 85/2) and flash fired; and one with modern lens (DA 35/2.4) and flash fired.

Attached Images
View Picture EXIF
PENTAX K-x  Photo 
View Picture EXIF
PENTAX K-x  Photo 

Last edited by ChooseAName; 09-15-2012 at 06:31 PM.
09-16-2012, 03:50 AM   #2
Veteran Member




Join Date: Mar 2009
Location: Chicago suburbs
Photos: Albums
Posts: 848
I don't know if this is your problem. I have a third party pTTL flash that works fine with my K200D, but doesn't work with my K-R. Seems Pentax changed the electronic settings in the newer cameras. You could contact Metz and see if there is a firmware update for your flash.
09-16-2012, 05:17 AM   #3
Veteran Member
ChooseAName's Avatar

Join Date: Aug 2009
Location: Southeast USA
Photos: Gallery | Albums
Posts: 390
Original Poster
QuoteOriginally posted by gp1806 Quote
I don't know if this is your problem. I have a third party pTTL flash that works fine with my K200D, but doesn't work with my K-R. Seems Pentax changed the electronic settings in the newer cameras. You could contact Metz and see if there is a firmware update for your flash.
Thanks! The firmware update fixed the problem. I didn't need to contact Metz because they have all their firmware updates on their website.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
fire, flash, k-x, k200d, lens, metz, mode, pentax help, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to power 540FGZ flash with Alienbees Vagabond mini II portable power? shadowbecomeswhite Flashes, Lighting, and Studio 2 07-25-2011 07:17 PM
K-x refuses to capture seww Pentax DSLR Discussion 4 12-26-2010 07:37 AM
Cactus v4 triggers, Pentax K20D and Metz 58 won't fire. luke_sheff Flashes, Lighting, and Studio 5 03-16-2010 12:05 AM
WTF? K100D now refuses to recognize non-DA lenses. mulanrouge Troubleshooting and Beginner Help 11 09-28-2009 01:03 PM
Big Iron - Fire Power of Another Era Sailor Post Your Photos! 23 06-20-2009 10:43 PM



All times are GMT -7. The time now is 02:08 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top