Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-18-2012, 03:47 AM   #1
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
K-5 SD card pictures disapeared

Just today I have returned back home from photo shooting and the pictures are not on the SD card. while taking pictures, the SD card was in the slot, no problems reported by camera, I could view the pictures while the card was in the camera. I am taking pictures in RAW

I have used the same card yesterday and all the pictures have been in and are still in the card. When I plugged the SD card back into camera, the picture are also not available in the camera anymore.

The today's folder also exists in the card, but it is just empty. I am having the K-5 for a year now and this has never happened.

Do you have any suggestions? Might use some undelete program to restore them or is it more serious?

Sorry if this has been already resolved in other post,

09-18-2012, 04:01 AM   #2
Inactive Account




Join Date: Sep 2011
Location: Melbourne
Photos: Gallery | Albums
Posts: 307
Are they on you computer? If so, is the transfer software you are use run on auto delete once copied?
09-18-2012, 04:26 AM   #3
Inactive Account




Join Date: Jan 2011
Location: Plymouth
Posts: 359
Give this a go, it works brilliantly. Recuva - Undelete, Unerase, File and Disk Recovery - Free Download Good luck.
09-18-2012, 04:47 AM   #4
Inactive Account




Join Date: Sep 2011
Location: Melbourne
Photos: Gallery | Albums
Posts: 307
QuoteOriginally posted by wildweasel Quote
Give this a go, it works brilliantly. Recuva - Undelete, Unerase, File and Disk Recovery - Free Download Good luck.
Dosen't recover PEF Raw files correctly - Photos are not usable

09-18-2012, 04:52 AM   #5
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
Original Poster
I will try to recover once I am back home. Recuva would be the first I will try. PhotoRec would follow.

SD has been opened by ordinary windows explorer under MS Windows 7
09-18-2012, 06:48 AM   #6
Site Supporter
Site Supporter




Join Date: Jan 2010
Location: Missouri
Posts: 107
I have had this exact same issue with a PNY card about 8 months ago and I know one other member who had the same issue with the same card. I have since thrown the card away and can't remember the exact model, but it doesn't happen to be PNY does it?

It was interesting because the card only deleted the pictures occasionally but it would happen the second I removed the card from the camera. All pics were visible in the camera until the card was removed.

Do any other cards have this issue on your K5?
09-18-2012, 06:55 AM   #7
Inactive Account




Join Date: Sep 2011
Location: Melbourne
Photos: Gallery | Albums
Posts: 307
I was going to suggest the same observation as turff.
09-18-2012, 07:21 AM   #8
Inactive Account




Join Date: Jan 2011
Location: Plymouth
Posts: 359
QuoteOriginally posted by bdparker Quote
Dosen't recover PEF Raw files correctly - Photos are not usable

It worked well for me last month with RAW files. Maybe an updated version to one you've tried before? Anyway, it's free so no harm in trying it out.

09-18-2012, 11:22 AM   #9
Forum Member




Join Date: Jul 2010
Location: Rosenheim, Germany
Posts: 54
Original Poster
@turff: This is exactly what I wanted to discuss. Is this a normal issue which is occurring because of the camera or the sd card or something else?
In my case it happened on Transcend SDHC Card, 32GB, Class 10. In three years I have used K-x, K-r and latest K-5 and this is the first time something like this happened.

I have just run the photorec and it found majority of the picture.
I will also later try the other programs and if any of those have been more / less successful.
09-19-2012, 02:58 PM   #10
cwe
New Member




Join Date: Sep 2012
Posts: 7
I have had the exact same issue on a K-7, PNY 8 GB class 10 card just once (don't remember if I was shooting RAW or JPEG). Have used the card afterwards (after formatting) without problems so far. However, I don't know if the problem is related to the camera or the SD card.
10-15-2012, 06:08 AM   #11
New Member




Join Date: Feb 2012
Posts: 8
Hi All

Had a very similar problem with my K200 at the weeend. Shot about 160 photos of my sons rugby match and could see the photos briefly as they were taken in the screen on the back.(camera does this automatically) At the end when trying to view the photos I got 2 messages one was No Image and the other was RAW....... but no photos. Tried switching on and off and removing and re-inserting the SD card to no avail.

I was shooting in raw and the camera showed the image count on the top screen. Got home and the card opened on the computer and showed the folders which were empty. It was a Scandisc Ultra 8 GB card. Ran the scandisc rescue pro (A free 1 year trial with a previous Scandisc purchase) and got all but 1 of the images back. All my other cards work fine in the camera on RAW and Jpeg except this one. As it was brand new and had only been formatted once in camera proir to this use I have to assume it is the card that is faulty not the camera. It goes back to the shop later today!!

Regards

André
10-15-2012, 12:35 PM   #12
Pentaxian
emalvick's Avatar

Join Date: Feb 2008
Location: Davis, CA
Photos: Gallery
Posts: 1,479
I've never had such a problem, but I've had my worries. I don't know how many times I've put an SD card into a reader to have Windows suggest that the card needs to be repaired. Windows then asks whether it should repair it for me. I've always suspected that such a repair could render the card unreadable, so I've never said yes. In each case, I've been able to get the photos off the card, but I tend to format the card (in the camera) after the images are removed.

The point of my post is that I don't trust Windows too much. It's suggestion that I need to repair my card or even the appearance of no files on the card are things I tend to ignore.

The potential for the loss of images being related to a card is possible, too. Just browse the net and reviews associated with SD cards. You'll be hard pressed to find a brand with no problems related to corrupt images or lack of images, and it happens with all cameras. PNY cards are notorious for these types of problems. SanDisk seem least likely, and many of the other brands seem to fall between.
11-30-2012, 07:33 AM   #13
Inactive Account




Join Date: Feb 2009
Location: Jakarta, Indonesia
Photos: Gallery
Posts: 35
Pentaxjaker12.. thanks for the link. Need to prepare if I encounter the same problem. Hopefully I won't, though..
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, k-5, pentax help, pictures, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SD card pictures corrupted on upload Spaceman Troubleshooting and Beginner Help 8 05-13-2011 09:50 AM
Forgot to format new card - can I save my pictures? T K Hull Pentax DSLR Discussion 7 06-13-2010 09:00 PM
Older SDHC card - can it affect your pictures? jpzk Pentax Camera and Field Accessories 4 04-30-2010 07:42 AM
Trouble copying pictures off memory card james_k_p Troubleshooting and Beginner Help 15 04-05-2010 11:43 AM



All times are GMT -7. The time now is 09:59 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top