Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-21-2012, 08:41 PM   #1
Inactive Account




Join Date: Sep 2012
Posts: 4
Problem with firware update and MF on K10D

Hi

This is my first post,so I hope I am doing this right. I have recently purcahsed a Sigma 50mm 1.4 DG SHM EX lens for my Pentax K10D. This is a beautfiul lens. I updated the firmware to version 1.31 to assist with the AF problem I was having. After updating the firmware the camera body recognised the lens in AF mode. However after shooting some photos this morning and accidentally leaving it on (the camera turned itself into sleep mode) I came back to find the camera body would no longer recognise the lens in AF mode, instead it recognises now if MF mode. Checked all the focus settings and they are all set to AF. Also tried a fresh battery and reinstalled the 1.31 firmware update. Has anyone had this problem before.

09-21-2012, 10:54 PM   #2
New Member




Join Date: Sep 2012
Posts: 20
seems familiar to the problem I've posted yesterday. Follow this thread and maybe you find the solution.
Jean-Marie
09-22-2012, 03:40 AM   #3
Inactive Account




Join Date: Sep 2012
Posts: 4
Original Poster
Thanks, your problem seems the same, except my lens initally worked when I did the firmware update and then stopped working afterwards.
09-23-2012, 09:34 PM   #4
New Member




Join Date: Sep 2012
Posts: 20
Have you tried downgrading the firmware to 1.30?
JM

09-23-2012, 10:18 PM   #5
Inactive Account




Join Date: Sep 2012
Posts: 4
Original Poster
I haven't, how would I go about that
09-23-2012, 11:33 PM   #6
New Member




Join Date: Sep 2012
Posts: 20
I just tried to downgrade the firmware to 1.30 & the camera gives me the message "Update file version is old. Cannot update". So I think this is not possible.
09-25-2012, 01:07 AM   #7
New Member




Join Date: Sep 2012
Posts: 20
Can you check the following: is the 'MF-indicator' in your viewfinder always ON while you change the AF.S-AF.C-MF switch?
Jean-Marie
09-25-2012, 04:10 AM   #8
Inactive Account




Join Date: Sep 2012
Posts: 4
Original Poster
Hi Jean-Marie

I looked at the camera and the MF stays on when I change drom MF to AF-C and AF-S whilst the new sigma lens is attached. It doesn't for my other lens. Does this happen to your camera?
Cheers
Rebecca

09-25-2012, 04:41 AM   #9
New Member




Join Date: Sep 2012
Posts: 20
Hi Rebecca,
it seems the same problem. I once more cleaned all the contacts, removed the lensmount to see if there is nothing bended inside this mount but nothing helps.
Last hope is that someone reads this message & help the both of us.
When I cannot find a solution I think to keep this body for my Sigma 10-20 & Pentax 100mm macro & find a second hand K10D-body.
Let's stay hopefull.
Jean-Marie
09-29-2012, 01:01 AM   #10
Senior Member




Join Date: Sep 2007
Location: Seattle
Posts: 245
QuoteOriginally posted by jmbroekaert Quote
I just tried to downgrade the firmware to 1.30 & the camera gives me the message "Update file version is old. Cannot update". So I think this is not possible.
I was also trying to downgrade the firmware and I got the same message "UPDATE FILE VERSION IS OLD. CANNOT UPDATE" I got my hacked firmware from: Vietzon.com

I wonder why it was possible to downgrade before and cannot be done now. If anyone figure out what this is not working, please chime in. Thanks.
09-29-2012, 08:56 PM   #11
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,134
I tried to downgrade from 1.31, and none of the hacks would work.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, body, camera, firmware, k10d, lens, mf, mode, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Who else are waiting for a firmware update for K-r to fix the FF problem analyze7 Pentax K-r 278 06-21-2011 06:16 PM
K10D Firmware Update jodikay79 Troubleshooting and Beginner Help 9 05-19-2011 01:07 PM
K-7 Firmware update problem! DonRicklin Troubleshooting and Beginner Help 8 01-13-2011 01:03 PM
Problem with AF after Firmware Update (*istDS) Hambino Pentax DSLR Discussion 2 10-09-2010 05:08 AM
Lens problem? update on FF of K-7 fulcrumx29 Pentax DSLR Discussion 6 08-16-2009 06:55 PM



All times are GMT -7. The time now is 02:05 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top