Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-24-2012, 10:52 PM   #1
New Member




Join Date: Sep 2012
Posts: 4
Shutter fires when using 50mm 1.4 Pentax M on KR

I have been using the 50mm 1.4 Pentax M M42 mount on my KR for the past 4 months without any problems but recently it started acting funny. The shutter fires whenever I press ANY button on the camera and it will keep on doing that until I use the 18-55 that came with it. Just want to ask if there is a fix for this. I normally use this lens more often than the 18-55 that came with it. I barely remove this from the camera. I followed every step in the article How to use/meter Manual & M42 Lenses on all Pentax DSLRs (K-5, K-r, K-x, K-7...). Im just wondering maybe it has something do with the adapter that I used. I got the Pentax M as a hand me down from my dad and the metal adapter I bought from Hidalgo Manila for about $10 .

09-24-2012, 11:09 PM   #2
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
Oh dear, sounds like your camera might have developed the dreaded "mirror flop". Search for that phrase here or on google, there's a lot of info on it.
09-24-2012, 11:51 PM   #3
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
https://www.pentaxforums.com/forums/pentax-k-r/195457-mirror-flop-issue.html.
09-25-2012, 12:00 AM   #4
New Member




Join Date: Sep 2012
Posts: 4
Original Poster
wow you guys work fast! will read this one =P

09-25-2012, 12:44 AM   #5
Veteran Member
kcobain1992's Avatar

Join Date: Dec 2010
Location: Bucharest, Romania
Photos: Gallery
Posts: 1,409
First of all, the Pentax M is not an M42 mount. Maybe you have a different lens?
Secondly, I'd appreciate a picture of the lens rear.
09-25-2012, 01:30 AM   #6
TZH
Senior Member
TZH's Avatar

Join Date: Aug 2010
Location: Kuala Lumpur
Photos: Gallery | Albums
Posts: 118
My K-r is having the same problem ... I would like to use my K-x rather than K-r when metering a M.

Last edited by TZH; 09-25-2012 at 04:43 AM.
09-25-2012, 04:32 AM   #7
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
QuoteOriginally posted by kcobain1992 Quote
First of all, the Pentax M is not an M42 mount. Maybe you have a different lens?
Secondly, I'd appreciate a picture of the lens rear.
You are right, a picture will help a lot. I think it might perhaps be a 1.4 Takumar, with a Pentax lens cap?
09-25-2012, 05:53 PM   #8
New Member




Join Date: Sep 2012
Posts: 4
Original Poster
I checked it last night, found out that the mirror also flops when there is no lens on the cam. It only stops acting normal when i put in the kit lens. I'l take a picture of the lens maybe it is a tak.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, 50mm 1.4 pentax, adapter, camera, fires, kr, m42, pentax, pentax help, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter fires in video mode dwsiii Pentax K-30 & K-50 24 08-09-2012 07:32 AM
shutter fires twice in single shot mode??? shang Pentax K-5 7 07-02-2012 11:26 PM
Pentax k5 with 50mm 1:1.7 and shutter speed smack1019 Pentax K-5 10 03-04-2012 03:52 PM
Original Pentax 645 only fires once in S mode then needs reboot Steinback Pentax Medium Format 3 01-22-2012 01:51 AM
Shutter only fires sometimes with manual lens - sears 50mm f1.7 jptruesdale Troubleshooting and Beginner Help 4 10-11-2011 08:16 AM



All times are GMT -7. The time now is 03:44 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top