Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-03-2012, 12:33 PM   #1
Forum Member




Join Date: Apr 2012
Posts: 71
mamiya rb67 flash?!?!?

i know this is a pentax forum but someone might know the answer. my problem is that i have a 90mm lens that wont fire the flash when connected to the x plug via pc cable, also i have a 37mm which fires slow on the 1 second exposure setting ie half way through the 1 second exposure the flash fires. are these problems fixable? are they hard to fix? or am i sol?

10-03-2012, 12:43 PM   #2
Pentaxian




Join Date: Jul 2009
Location: Seattle
Posts: 7,103
How good a fit is the connection? My PC cable does not fit my Pentax 6x7 very tight and often does not fire. My Hasselblad lenses has a locking feature for the PC cable, fits snug and fires every time.
10-03-2012, 12:45 PM   #3
Forum Member




Join Date: Apr 2012
Posts: 71
Original Poster
solid connection, i found out how to fire the 90mm. i have to force the lever down hard for it to cock the lens all the way i guess.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
exposure, fires, flash, mamiya rb67, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone use/consider Mamiya systems? dugrant153 Non-Pentax Cameras: Canon, Nikon, etc. 17 12-20-2010 08:14 PM



All times are GMT -7. The time now is 11:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top