Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-04-2012, 06:08 PM   #1
Inactive Account




Join Date: Mar 2011
Posts: 9
K10 Issue

Hi all,

My k10 consider total lost.

My k10 after click the shutter than the CCD close down and that it's.

No matter how I click no function at all.

Can anyone can explain to me or face this before.

Thanks!

10-04-2012, 09:06 PM   #2
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,424
I hate to ask, but what is the status of the battery? Charged? If charged, it still might not be able to power the camera if it old. Lithium cells have a finite age.


Steve
10-05-2012, 12:16 AM   #3
Inactive Account




Join Date: Mar 2011
Posts: 9
Original Poster
HI Steve,

I have 2 units of battery. Both battery already fully charge and try it out. My K10D no response at all.
My 2 units of battery is working with my friend K10D unit.

My K10D CCD shutter closed than no pop up back. I try to trigger next photo shot the trigger not response at all.
10-05-2012, 10:49 AM   #4
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,533
just an idea but did you try running it through the 8.3 volt dc port?
maybe your battery terminals are too corroded... or if you can borrow a grip with the extra battery and see if it will power up that way. that way you can rule out if it is a power problem or if it is really dead

good luck

randy

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
click, k10, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: Broken K10, or K10 Prism Dave Sold Items 2 01-26-2012 01:36 PM
K10 AF issue ogre Pentax DSLR Discussion 3 11-03-2011 11:55 AM
Memory Card issue with K10 VTPentax Pentax DSLR Discussion 6 04-05-2010 05:22 AM
K7 Buffer Issue? samholton Pentax DSLR Discussion 4 01-08-2010 07:19 AM
K10d image quality question/issue vagabond79 Troubleshooting and Beginner Help 7 11-12-2009 12:29 PM



All times are GMT -7. The time now is 02:56 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top