Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-22-2012, 01:48 PM   #1
New Member




Join Date: Oct 2012
Posts: 7
Lens Trouble

Hi, I'm Sara Grace and I need a little help. I have a Pentax Kx DSLR. First, let me say that I am NOT a camera guru, but I surely love taking photos and am learning a few things. I take my camera everywhere. Anyway, my husband and I previously owned the old Sears brand 35mm, which we understand was made my Pentax for Sears. All the lens for that camera would fit any of the Pentax cameras. So, I bought this camera not quite 2 years ago. It has recently become stuck in manual mode. (Yes, only I could manage that, I'm sure.) My camera goes everywhere with me, even to work on occasion.

I wanted a larger lens that those I have, so I found a Sigma 70-300mm and my hubby bought it for me. It has worked great until recently. Not long ago, I was trying to take pics with it and it would not snap the shot. I kept working and working with it and it would do nothing. I pulled out my book to troubleshoot, which was not use at all. Finally, I thought I'd just take the batteries out and put a new set in, although those that were in there still had plenty of juice. Well, it started working fine. Then yesterday, I'd put the large lens on to take some photos at the lake. It would not do a thing. I went back to the car and put my smaller lens on and it just snapped away. Do you think it could be the batteries or do I not have the setting correct? Help please!!

10-22-2012, 02:02 PM   #2
Veteran Member
oxidized's Avatar

Join Date: Dec 2009
Location: USA - Delaware
Photos: Albums
Posts: 434
So you are only operating the camera in manual mode? The only time I have experienced this kind of problem is when I am using auto focus and the camera cannot lock onto a focus point because its too dark, it hunts around and then just stops (refusing to take the picture). Have you tried using the lens in manual focus mode?
10-22-2012, 02:03 PM   #3
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,616
Welcome to the forum! I've moved this from the Welcomes and Introduction forum as you will likely get a quicker answer here.
10-22-2012, 02:04 PM   #4
Giveaway winner!
MysteryOnion's Avatar

Join Date: Dec 2007
Location: beantown
Photos: Albums
Posts: 933
Exactly which Sigma 70-300?

I read something earlier about optical stabilized lenses eat battery power.

10-22-2012, 02:08 PM   #5
Senior Member
Kona's Avatar

Join Date: Aug 2011
Location: Victoria
Photos: Albums
Posts: 202
My K-r has a setting somewhere to not fire without focus confirmation. Are you sure you're getting focus locks with it? I found it quite annoying and disabled it since it could be quite inaccurate (particularly for macro work). May also just want to clean the contacts. I've noticed some lenses acting oddly when contacts are dirty.
10-22-2012, 04:08 PM   #6
Senior Member
usmcxm35's Avatar

Join Date: Jun 2010
Location: New York, USA
Photos: Gallery | Albums
Posts: 215
Have you tried to take pictures while in Live View Mode? That way you can work the lens a little and see what's going on.
10-22-2012, 04:20 PM   #7
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,939
Silly question, but are the contacts on the lens dirty? Try cleaning them if they seem off, there could be a coating of whatever on the lens mount thats causing the camera to not recognize the lens.
10-23-2012, 10:03 AM   #8
New Member




Join Date: Oct 2012
Posts: 7
Original Poster
Thank you. I will.

10-23-2012, 10:08 AM   #9
New Member




Join Date: Oct 2012
Posts: 7
Original Poster
Thank you. I'm getting a lot of helpful info that I have not tried. I will try it though.
10-23-2012, 10:09 AM   #10
New Member




Join Date: Oct 2012
Posts: 7
Original Poster
No, I've not worked in live mode at all. I'm not all so savvy when it comes to this camera. I'll try this too. Thank you.
10-23-2012, 10:11 AM   #11
New Member




Join Date: Oct 2012
Posts: 7
Original Poster
I'm not exactly sure which Sigma I have. I'll have to look when I get home. Thank you.
10-23-2012, 10:13 AM   #12
New Member




Join Date: Oct 2012
Posts: 7
Original Poster
I can only use the manual focus. Pentax support told me it was locked in manual focus. It won't auto focus at all.
10-23-2012, 10:15 AM   #13
New Member




Join Date: Oct 2012
Posts: 7
Original Poster
Thank you all for the suggestions. I'll be sure to try them when I get home. When my camera doesn't work properly, it's right up there with having trouble with your car!!LOL
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, camera, lens, pentax, pentax help, photos, sears
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble auto-focusing with K7 SLR and Tamron 18-200mm lens Joan55 Troubleshooting and Beginner Help 4 07-01-2012 08:06 PM
Pentax-M lens -- trouble stopping down bklonoski Pentax SLR Lens Discussion 2 09-02-2011 07:59 PM
K-R trouble focusing in low light with Live View using Pentax 18-55 kit lens sportv Pentax K-r 8 01-02-2011 06:42 PM
still having trouble with this lens Deiberson Troubleshooting and Beginner Help 4 12-27-2009 02:44 PM
Help! Having trouble with lens lineup... maxwell1295 Pentax SLR Lens Discussion 11 04-24-2008 04:56 PM



All times are GMT -7. The time now is 01:53 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top