Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-22-2012, 05:48 PM   #1
Senior Member
rangercarp's Avatar

Join Date: Oct 2012
Location: Michigan, Kansas, New Mexico
Posts: 224
AF360 issue

I purchased the AF360 last week, new from B&H. At first I could not get it to fire at all. I tried a second set of batteries, changed lenses, moved it from my K-5 to my K10D, and tried it detached from the camera, all to no avail. It was clearly communicating with the camera, but The ready light would not come on at all. Later in the day I was able to get it to fire a couple times, but never in succession without shuffling through the modes and back to p-ttl. Most of the time the ready light would go out as soon as I pushed the shutter button half way. The next day I gave it another try, and this time it worked just fine. Over the course of the day I gave it several tires. It recycled very quick and seemed to work just like it should. Today it was being very finicky again. With some effort I could get it to fire, but it would not recycle unless I scrolled through all the modes and back to p-ttl.

This is my first time using a hot shoe flash on my Pentax (I have used them before on Olympus cameras), so I am wondering if I am doing something wrong, or if it is a dud and I need to send it back to B&H? Both sets of batteries I tried were new out of the box, though they had sat in my drawer for a couple years. They red-lined my battery tester on the fully charged end of the gauge.

Any advice will be much appreciated!

10-22-2012, 08:14 PM   #2
Pentaxian




Join Date: May 2010
Photos: Albums
Posts: 604
QuoteOriginally posted by rangercarp Quote
Any advice will be much appreciated!
First thing to make sure is turn the camera on first followed by the AF360FGZ (flash should be already on the shoe), not other way. To have an effective communication between the camera and flash (My sequences):
1) Flash mounted on the Camera (with DA, FA lens mounted)
2) Turn on Camera
3) Turn on AF360FTZ
Flash display should show P-TTL, correct closest focal length, etc.

If you have already done those and flash does not work properly/consistently then Flash is faulty.

Last edited by ultraviolet; 10-23-2012 at 06:38 PM.
10-23-2012, 06:19 PM   #3
Senior Member
rangercarp's Avatar

Join Date: Oct 2012
Location: Michigan, Kansas, New Mexico
Posts: 224
Original Poster
I'm not sure if I have been following that order or not, but I am now. Tonight it is working just fine. This morning I could not get it to work at all, but I may have turned the flash on first, I'm not sure.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af360, batteries, camera, couple, day, fire, light, modes, p-ttl, pentax help, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AF360 underexposure Rusty Rat Troubleshooting and Beginner Help 6 11-16-2013 03:36 PM
HELP__645N and AF360 flash photofreek Pentax Medium Format 7 01-06-2012 10:53 AM
Over-Exposure problem on K-7 + AF360: please help! mxlinn Flashes, Lighting, and Studio 4 11-27-2011 07:46 AM
For Sale - Sold: DA 15, DA 40, DA 70, DA 16-45, DA L 55-300, AF360 (Worldwide) yoshizuki Sold Items 23 10-22-2011 03:24 PM
a few more af360 questions Deiberson Troubleshooting and Beginner Help 8 12-23-2010 05:47 PM



All times are GMT -7. The time now is 08:27 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top