Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-30-2012, 08:38 AM   #1
Forum Member




Join Date: Jun 2007
Location: quebec
Photos: Gallery
Posts: 75
K5 and Metz 58 non consistant exposure in slave mode

Hello.
Im strugling with my Metz 58 AF2 in slave mode trying to figure out what is going wrong.
For no apparent reason it produce very under exposed shots 2 or 3 in a row and 6 or 7 well exposed shots.
I did try many different setting betwen auto and manual setting. mouved things around, removed and covered all reflective things in the studio and still getting under exposed shots for no visible reason.

The k5 is set on control mode and W.
The metz and k5 are on tripods 2 feets appart, the metz is in front on the camera one feet to the right. and the target is 6 feets in front of the camera.
both are firmware updated to v 1.13 and v 3 for the metz.

Do you have a clue?

have a nice day.

10-30-2012, 11:09 AM   #2
Senior Member
usmcxm35's Avatar

Join Date: Jun 2010
Location: New York, USA
Photos: Gallery | Albums
Posts: 215
I didn't know that v3 was out for the Metz 58 AF2, by any chance, would you happen to have an aftermarket focus screen installed? Metering might be off on the Body itself.
10-30-2012, 11:14 AM   #3
Forum Member




Join Date: Jun 2007
Location: quebec
Photos: Gallery
Posts: 75
Original Poster
I did more testing with the k20d. some different lens and camera combo. and the Metz on slave mode. And on camera.

I did the same testing with the da 35, the sigma 70-200, the tamron 28-75, and a pentax A 70-210. on the k5 and k20.

The problem was only visible with the sigma 70-200 f2.8 and k5 combo in slave mode showing unconsistent exposure.

All other lens and camera combo work fine.

I put fresh bat and clean the contac but this was not convincing. The k5 just dont like the sigma. I have no clue since the sigma just work fine on the k20.

The pentax A 70-210 f4 and k5 is a great combo with the metz.



Have fun.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, front, k5, metz, mode, pentax help, shots, slave
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bower flash wont sync in slave mode. haassaasin Flashes, Lighting, and Studio 3 08-23-2015 09:16 AM
Metz 50- Optical slave? FrumPilot Flashes, Lighting, and Studio 4 02-03-2012 06:32 AM
Metz slave mode preflash suppression octavmandru Pentax K-5 9 01-08-2012 03:20 PM
Metz 58AF -2 Optical slave Chaos_Realm Flashes, Lighting, and Studio 9 10-02-2011 04:00 PM
Metz 58 as remote slave mhertel Flashes, Lighting, and Studio 6 08-24-2008 11:28 PM



All times are GMT -7. The time now is 09:49 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top