Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-09-2012, 04:36 PM   #1
Senior Member
Vindemiatrix's Avatar

Join Date: Oct 2012
Location: las vegas
Posts: 209
Random problem with k5 and d fa 100 wr

I was in my backyard taking pictures of myself with this setup and a remote (lame I know :P)

anyway all of a sudden the camera stopped setting the aperture on the lens, the pictures came pitch black and the aperture on the display said F--. I changed modes did a little fiddling with the camera and the only thing that worked was taking the lens off and putting it back.

fiuuu that was a scare, could there be a problem with the lens? does this happen often to anyone, just a hiccup??

11-09-2012, 04:40 PM   #2
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
The F-- indicates that the lens and camera are not communicating. WIpe down the lens and camera mount contacts and hopefully you will not see it again.
Your taking the lens on and off may have removed any gunk that was blocking contact, but it is strange that it happened in the middle of shooting.
11-09-2012, 04:42 PM   #3
Site Supporter
JimJohnson's Avatar

Join Date: Jan 2012
Location: Lake Superior - Michigan
Photos: Gallery
Posts: 2,271
Is there ANY chance the aperture ring wasn't FULLY locked on the 'A' position? If the aperture ring was not quite locked, switching to 'F - - -' (means the lens is not an 'A' capable lens) might have happened with the vibration of the mirror movement. Taking the lens off and putting it back on, may may returned the lens to the 'A' position.
11-09-2012, 04:44 PM   #4
Senior Member
Vindemiatrix's Avatar

Join Date: Oct 2012
Location: las vegas
Posts: 209
Original Poster
hmm there was a lot of wind and dust out there. I hope it won't happen again

11-09-2012, 04:49 PM   #5
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,797
QuoteOriginally posted by JimJohnson Quote
Is there ANY chance the aperture ring wasn't FULLY locked on the 'A' position?
DFA100WR does not have an aperture ring.
11-09-2012, 04:56 PM   #6
Site Supporter
JimJohnson's Avatar

Join Date: Jan 2012
Location: Lake Superior - Michigan
Photos: Gallery
Posts: 2,271
Sorry forgot the WR version of this lens doesn't have an aperture ring ... the non-WR version does have an aperture ring.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, camera, lens, pentax help, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-30 and D-FA 100 WR isb.deep Pentax K-30 & K-50 11 09-05-2012 01:42 PM
Impromptu Acquisition - D-FA 100 2.8 Macro WR SOldBear Pentax SLR Lens Discussion 11 08-29-2012 11:50 PM
For Sale - Sold: DA 21, 40 and 70, D FA 100 WR and FA 50/1.4, all EX++(Canada) farfisa Sold Items 11 04-23-2012 06:38 AM
D FA 100/2.8 WR owners: problem? Todd Adamson Pentax SLR Lens Discussion 4 06-10-2011 12:05 PM



All times are GMT -7. The time now is 10:36 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top