Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-13-2012, 01:32 PM   #1
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,157
K-30 mechanical sound

I've had my K-30 for some months. Never had any real problems but tonight it produced a weird sound:

Normal sound and ambient noise reference:
Weird sound - recorded some 20 mins later:

The sound occurs when taking pics as well. It starts once the shutter button is fully pressed and stops about a second later.

I tried disabling SR in movie mode. Didn't help.
I tried reinserting the batteries. Didn't help.

Battery was very low. So low that I could only turn the cam on again after removing the batteries. The weird sound occurred after this - I tried again once I got home (on the same set of batteries) but this time couldn't reproduce the sound. Could be a random low battery thing, but as you might agree on, it's very worrying.

Ideas?


Last edited by Zafar Iqbal; 11-13-2012 at 02:54 PM.
11-13-2012, 03:06 PM   #2
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,065
Sounds like the sensor-block suspension circuit is in overdrive. I would lean towards a low battery induced random condition.
Could also be that the mic. gain control circuit had a hick-up and went way up in gain ( maybe).
11-13-2012, 04:26 PM   #3
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,157
Original Poster
I don't know anything about such stuff but I hope and in a way suspect you may be right.
11-13-2012, 04:31 PM   #4
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,065
QuoteOriginally posted by Zafar Iqbal Quote
I don't know anything about such stuff but I hope and in a way suspect you may be right.
Just keep using it, if it acts up again, then maybe warranty service will be in order.

Cheers.

11-13-2012, 04:39 PM   #5
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,157
Original Poster
Yeah, I will. Been taking more shots (for other reasons) tonight and it haven't repeated the sound.
11-14-2012, 02:28 PM   #6
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,157
Original Poster
The service folk here couldn't tell me what may have been causing it. Instead they suggested I send in the camera but at the risk of having to pay for their time.

They should know a bit more about the cameras they work with, should they not?
05-21-2013, 09:14 AM   #7
New Member




Join Date: May 2013
Posts: 2
I'm having the same issue but it never stops, its like the LCD screen that makes the sound because when I'm takes pictures and using the screen I can also hear the sound... Annoying, is there any way to solve it ?
05-21-2013, 10:34 AM   #8
Pentaxian
Zafar Iqbal's Avatar

Join Date: Oct 2010
Photos: Gallery
Posts: 1,157
Original Poster
I never solved it and it only occurs when in video mode - but not always.

05-21-2013, 06:06 PM   #9
Site Supporter
ramseybuckeye's Avatar

Join Date: Apr 2009
Location: Elida, Ohio
Photos: Gallery | Albums
Posts: 8,124
I had a similar sound doing a still shot, saw that the focus lever was not locked and and sitting between AFS and C. I moved it into position and no more noise.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, help, k-30, pentax help, sound, youtube
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
So Confused.. K-5 IIs or K-30??? Racerdew Pentax DSLR Discussion 53 12-07-2012 10:07 PM
My k-30 have problem? mengazaa Pentax K-30 & K-50 19 11-10-2012 06:42 AM
Definitive Ruling on K-30 Shutter Sound? Basset Pentax K-30 & K-50 71 11-06-2012 02:11 PM
Korean K-30 Focus-Peaking Test (and Overall K-30 Review) Welfl Pentax K-30 & K-50 8 08-23-2012 01:06 PM
K-30 Clicking/Rattling Noise iunknown Pentax K-30 & K-50 7 07-08-2012 02:07 PM



All times are GMT -7. The time now is 04:12 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top