Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-14-2012, 06:49 AM   #1
New Member




Join Date: Nov 2012
Posts: 2
K10d not recognising AF lens

I have a K10d and it has stopped recognizing AF lens when I put an AF lens in it asks to input the focal length for the shake control and when ive done that it says MF in the view finder .this is with all AF lens's including the Pentax kit lens's

11-14-2012, 07:06 AM   #2
Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 952
First step is to make sure the contacts are clean. Carefully clean the contacts in the body mount (and in the lens as well to make sure). You can use an eraser or a very fine grit sandpaper GENTLY. Check to see if any of the contacts look damaged or different.
Hope this helps.

Thanks,
11-14-2012, 07:27 AM   #3
Site Supporter
JimJohnson's Avatar

Join Date: Jan 2012
Location: Lake Superior - Michigan
Photos: Gallery
Posts: 2,165
In addition to cleaning the contact points, make sure all the screws for your body's mounting flange are snug. When mounting a lens, hold in the release button, turn the lens all the way into the mount, release the lens release button and turn the lens backwards in the mount until the lock clicks. If you still do not have full lens functioning, try slowly rocking the lens slightly clockwise / counter-clockwise and watch to see if you get a connection.
11-14-2012, 11:34 AM   #4
New Member




Join Date: Nov 2012
Posts: 2
Original Poster
Well I combined the advice given by both ismaelg and Jim Johnson and it worked I honestly cant say which as I did them both at the same time. but I would like to thank both of you

11-14-2012, 12:27 PM   #5
Site Supporter
ismaelg's Avatar

Join Date: Apr 2009
Location: Puerto Rico
Photos: Gallery
Posts: 952
Since I wrote first I should get 51% of the credit!

Just kidding
Glad it worked!

Thanks,
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, k10d, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10d: AF-leds are not alligned in AF-frame jmbroekaert Troubleshooting and Beginner Help 5 10-17-2012 03:47 AM
k-5 not recognising 17 mm Pentax-M fisheye disco_owner Pentax K-5 5 04-22-2012 07:50 PM
K10D AF not locking Geekybiker Troubleshooting and Beginner Help 3 06-02-2011 01:57 PM
K10D not regonizing AF lens as AF Time Freeze Pentax SLR Lens Discussion 6 12-13-2007 11:30 AM
K10D: Center AF point not centered Photomy Pentax DSLR Discussion 14 02-10-2007 05:22 PM



All times are GMT -7. The time now is 09:33 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top