Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-22-2012, 04:42 AM   #1
New Member




Join Date: Nov 2012
Posts: 3
K100D takes all black photos...

I have a K100D that suddenly started taking all black images. It still sounds the same when it takes a photo and everything else (the lcd screen, menus etc,.) are working normally. I checked with the lens off and the mirror is moving when a picture is taken. I've tried fresh batteries and letting the camera sit for awhile and resetting it. No luck. Same problem even in manual mode and with manual focus.

I'm thinking maybe the shutter is stuck?

Any other suggestions on what I can try?

11-22-2012, 05:58 AM   #2
New Member




Join Date: Nov 2012
Posts: 3
Original Poster
Upon further review it's definitely the shutter. It's not actuating when pictures are taken. I put the camera in sensor cleaning mode and long exposures and the shutter stays closed.

Is there anything at all I can do in this case?
11-22-2012, 06:11 AM   #3
Pentaxian
newmikey's Avatar

Join Date: May 2007
Posts: 1,602
QuoteOriginally posted by Camerax Quote
Upon further review it's definitely the shutter. It's not actuating when pictures are taken. I put the camera in sensor cleaning mode and long exposures and the shutter stays closed.

Is there anything at all I can do in this case?
To be honest: no. You could have it repaired but for the price of the repair you'd be able to purchase a used K20D which is a huge step up. I loved my K100D (the Super) at the time but with all of the improvements that have happened over the past 4 -6 years: do yourself a favour and either get one of the last legacy K-5's out there while they last or, if you have less financial leeway, pick up a used K20D.
11-23-2012, 02:14 PM   #4
New Member




Join Date: Nov 2012
Posts: 3
Original Poster
Bummer.

It appears that the rear shutter doesn't open but the front one does...I don't know if that makes sense, but it's like the first part of the shutter that lifts up works but the back shutter that drops down doesn't work. I put the camera on sensor cleaning mode and gently reached in with a latex glove on the back shutter dropped to the bottom when I touched it. I'm not sure what the actual problem might be but it's probably an expensive fix.

11-23-2012, 03:08 PM   #5
Pentaxian
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 14,173
As mentioned, for the price of the repair of your K100, you could get something newer/better. I see K100s pop up in the Marketplace for ~$150 or even less, so you could keep your eyes open if you really liked the camera. (or place a "wanted" ad) Good luck.
11-23-2012, 03:17 PM   #6
Veteran Member
borno's Avatar

Join Date: Nov 2006
Location: md-usa
Photos: Gallery | Albums
Posts: 2,580
You may be surprised at how much broken stuff can get on ebay (with full disclosure,of course) You might get almost enough for another used one. I guess people need parts, or like to tinker. I got $100 or so for a broken laptop a while back, and was happy.
11-23-2012, 04:00 PM   #7
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,883
QuoteOriginally posted by Camerax Quote
Bummer.

It appears that the rear shutter doesn't open but the front one does...I don't know if that makes sense, but it's like the first part of the shutter that lifts up works but the back shutter that drops down doesn't work. I put the camera on sensor cleaning mode and gently reached in with a latex glove on the back shutter dropped to the bottom when I touched it. I'm not sure what the actual problem might be but it's probably an expensive fix.
The repair is probably replacing the shutter, which is not conveniently located. I'll give you $30 for the camera as-is. (I might be able to combine it with my brother's old *ist DL with a failed sensor.)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k100d, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Streets It takes all kinds ........ daacon Post Your Photos! 15 07-12-2012 06:21 AM
black gradient on bottom of all photos shot with k10d controlapparatus Troubleshooting and Beginner Help 13 07-21-2011 11:01 PM
*istDL Takes Black Pictures tpx60s Troubleshooting and Beginner Help 26 01-29-2011 08:54 AM
k100d takes the K100D to a wedding k100d Pentax DSLR Discussion 13 09-18-2008 12:10 PM



All times are GMT -7. The time now is 04:31 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top