Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-27-2012, 02:49 PM   #1
Inactive Account




Join Date: Aug 2010
Location: iASI
Posts: 6
Pentax KX dslr unresponsive

Hello everyone.
When i insert new batteries in it, my KX dslr starts directly with date/time screen, and everything remains unchanged when i press any button. I think it might be broken but who knows maybe is just loked somehow...
If someone can help, thanks in advance.

11-28-2012, 12:07 AM   #2
Senior Member




Join Date: Apr 2012
Location: Sweden
Posts: 185
Take the batteries out, make sure the SD card is out as well. Than insert only the batteries and switch on. It may have 'frozen' (like Windows does if something it doesn't like is inserted) due to a faulty SD card, or a faulty camera connection to the SD card. If it still hangs than go to the nearest camera shop and get them to see it.
I would also think if you are able to get to start it without the SD card, than perhaps reformat the camera via the menu so it starts fresh and hopefully be able to accept SD cards again.
12-01-2012, 03:33 AM   #3
Inactive Account




Join Date: Aug 2010
Location: iASI
Posts: 6
Original Poster
Thank you for the fast reply Voyager13.
I tried to start the K-X with and without the SD card several times but the result is the same, it starts directly with "Date Adjustment" screen and nothing changes when i press any button.
In this case i don't think the defect in from the SD card socket because when i insert the SD card an red LED on the back of the dslr lights for a second and only after that the display appears.
I will look for an repair shop or i will try to take a look inside myself.
12-01-2012, 06:38 PM   #4
New Member




Join Date: Apr 2008
Location: USA
Photos: Gallery
Posts: 21
QuoteOriginally posted by voyager13 Quote
Take the batteries out, make sure the SD card is out as well. Than insert only the batteries and switch on. It may have 'frozen' (like Windows does if something it doesn't like is inserted) due to a faulty SD card, or a faulty camera connection to the SD card. If it still hangs than go to the nearest camera shop and get them to see it.
I would also think if you are able to get to start it without the SD card, than perhaps reformat the camera via the menu so it starts fresh and hopefully be able to accept SD cards again.
Had trouble with my kx, power being drained lost all functions no power. Inserted new batteries no power. Look at this fourum post tried without sd card and now camera functions perfect. I will be tossing that sd card. Thanks for this tip...

12-02-2012, 12:12 AM   #5
Senior Member




Join Date: Apr 2012
Location: Sweden
Posts: 185
QuoteOriginally posted by pegassuss Quote
an red LED on the back of the dslr lights for a second
That red light appears everytime one plugs in a SD card and that's the camera's way of saying 'I have registered the SD card'. I am out of ideas as to what to do about the camera, perhaps someone more technically experienced may have something to say here. Otherwise would be a good idea to take it to a repair shop.

bcat - Am happy it worked for you.
12-06-2012, 07:37 PM   #6
New Member




Join Date: Apr 2008
Location: USA
Photos: Gallery
Posts: 21
QuoteOriginally posted by voyager13 Quote
That red light appears everytime one plugs in a SD card and that's the camera's way of saying 'I have registered the SD card'. I am out of ideas as to what to do about the camera, perhaps someone more technically experienced may have something to say here. Otherwise would be a good idea to take it to a repair shop.

bcat - Am happy it worked for you.
Camera is now dead and will not power up..
12-08-2012, 08:43 AM   #7
Inactive Account




Join Date: Aug 2010
Location: iASI
Posts: 6
Original Poster
Hi.
By searching the forums i discovered the Debug mode for the dslr.
So i create one file called MODSET.492 and in it i writed this line: [OPEN_DEBUG_MENU] folowed by enter, loaded this file to the SD card and i powered up the dslr with the card inserted.
Now the display lit but remains black (no date setting screen anymore) and in the viewfinder apears some changing info about shutter speed, ISO, aperture and others(if i press the shutter button a hand apears, focus confirmation when the subject is in focus with SMC A 50mm f1.7, etc) allso the viewfinder info changes when i rotate the mode dial and the flash pops up when i press the coresponding button, however i cannot take pictures and .
Encouraged by my new discovery i continued and modified the content of the MODSET.492 with this one [USR_DAT_CLEAR] . Now if i insert new batteries ithe dslr starts as it should do: directly with Language Settings screen, not Date Settings screen anymore, however iven so the dslr remains unresponsive.
I went iven deeper with: [DSP_ROM_STORE] and after the WAIT... and COMPLETE messages the dslr has writed a 10Mb file called KB492DSP.BIN to the SD card . However when i tried the [CPU_ROM_STORE] the message WAIT... remains on the screen indefinitely and if i take the batteries out and check the SD card i found a 0 bytes KB492CPU.BIN file. I think the cpu is dead for some reason.
Now i wish to reflash the firmware at least for the cpu but in the actual state i don't know if that is possible.
The dsp seems ok so I tried [DSP_ROM_LOAD] and [DSP_ROM_WRITE] but they don't work because i think these are no valid comands. If someone can help thankyou in advance.
Regards.
01-10-2013, 11:18 PM   #8
Inactive Account




Join Date: Aug 2010
Location: iASI
Posts: 6
Original Poster
I went to a repair shop and they said that the mainboard is faulty but the repair cost is too high over 100 $.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
dslr, kx, pentax help, pentax kx dslr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma lens SA/KPR mount....usable on Pentax KX DSLR?? pokolbinguy Pentax SLR Lens Discussion 7 11-04-2014 04:54 PM
After 4 Pentax DSLR, a first failure: Kx Died! BBear Pentax DSLR Discussion 13 10-16-2010 11:30 AM
New Lens for my first DSLR - Pentax KX true_scotsman Troubleshooting and Beginner Help 19 07-30-2010 04:08 AM
My first ever DSLR...the Pentax Kx LudaDave Troubleshooting and Beginner Help 44 07-13-2010 07:18 AM
[TIPA awards 2010] Pentax Kx best entry level dSLR sterretje Pentax News and Rumors 2 05-03-2010 07:17 AM



All times are GMT -7. The time now is 03:21 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top