Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-12-2013, 08:49 PM   #1
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,531
Lens contacts, contact or else ...

My K-7 started to develop a problem which may be linked with dirty lens contacts, I believe.

With three different lenses, I noted that the camera top LCD started to show, after a while, the indication F----. The AF still works, but I lost Aperture information. If I swicthc off the camera, remove and re-insert the lesn, it may solve the problem for a short while. Alternately, I would clean the contacts with a soft dry cloth at home and everything would work fine for sometimes (a few days). (There is an interesting discussion on lens contact cleaning at https://www.pentaxforums.com/forums/pentax-beginners-corner-q/188228-cleaning...-contacts.html.)

- Is this behaviour typical of dirty contacts?

- Is there a specific contact which would cause this? Or is this a combination of all/several contacts? (I am thinking that there might be a faulty contact [singular], but which one?)

- Alternately, could this be caused by the lens mount (eg untightened)?

Any input is most welcome. If I cannot fix it myself, I would off course consider to service the lens (and any suggestion for service in Australia is welcome).

Thank you.

01-12-2013, 10:53 PM   #2
Loyal Site Supporter
Bruce Clark's Avatar

Join Date: Mar 2010
Location: Brookfield, Victoria
Photos: Gallery | Albums
Posts: 3,768
Having same issues with my K-7 and Sigma 105mm Macro. It seems spasmodic and is readily, albeit temporarily, fixed by dismounting and remounting the lens. It has not overly bothered me yet but if it is a symptom of a developing problem it might be timely for a more thorough investigation and fix.
01-13-2013, 12:45 AM   #3
Pentaxian




Join Date: Oct 2006
Location: Chicago suburb, IL, USA
Posts: 1,535
Hi hcc and Bruce,

Take a look at this site -- though the mod is not relevant, you can get some insight to what each of the pins does.

http://www.robertstech.com/matrix.htm

The contact that you probably need to concentrate on is the "A" pin since AF seems not to be effected. Inspect the "A" pin on both the lens and body for any oil, dirt corrosion, or oxidation. Also try spanning a straight edge supported on adjoining pins to see if the pin is no protruding to the same distance as the others.

Scott
01-13-2013, 01:24 AM   #4
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,531
Original Poster
QuoteOriginally posted by snostorm Quote
Hi hcc and Bruce,

Take a look at this site -- though the mod is not relevant, you can get some insight to what each of the pins does.

http://www.robertstech.com/matrix.htm

The contact that you probably need to concentrate on is the "A" pin since AF seems not to be effected. Inspect the "A" pin on both the lens and body for any oil, dirt corrosion, or oxidation. Also try spanning a straight edge supported on adjoining pins to see if the pin is no protruding to the same distance as the others.

Scott
Scott
Thanks. Will follow the advice and see if it helps.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, contact, contacts, lens, pentax help, service
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Image quality: DA 16-45 f4 or FA 28-105 f4-5.6 or something else? fanofcc Pentax SLR Lens Discussion 18 10-10-2013 05:07 PM
K7 Lens contact sensor Idahovaldt Troubleshooting and Beginner Help 2 03-23-2012 12:22 PM
RZ10 or something else? ChopperCharles Pentax Compact Cameras 3 09-13-2011 01:37 PM
Anyone has a reliable contact for service from sigma Canada or USA? bdery Flashes, Lighting, and Studio 3 06-24-2011 06:45 PM
Advice on a new lens - Bigma or something else? Techno~ Pentax SLR Lens Discussion 16 02-28-2008 05:58 AM



All times are GMT -7. The time now is 03:21 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top