Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-17-2013, 10:51 AM   #1
Pentaxian




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,191
K-5 IIs hangs with built-in flash!

Been trippin around with two new lenses when I decided to use the built-in flash because I was feeling too lazy to mount my Metz on it.

Then the K-5 IIs stuck up, after a flash or two.

I tried to find the cause of the problem, and here it was:

1 battery (still green) in the grip, none in the body. Could it be a stability issue?

It works all fine until I press the switch for the built-in flash - at which point the cam freezes, even if I turn the power to "off" (it does power off after 10 or so seconds).

I tried solving the issue by putting the batt in the body - it worked. What I'm wondering about is, I've used the camera before with no battery in the body and only in the grip, and used the flash in that manner too... it was working then. I have no idea why it hangs the camera now.

01-17-2013, 12:29 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,978
I've had my K-5 shut itself off when the battery in the body was low and I tried using the flash or lV, even though the grip battery was fully charged and selected as the primary power source. So I think there may be some unresolved issues in this respect.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-20-2013, 06:01 AM   #3
Pentaxian




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,191
Original Poster
I guess there really are some bugs still. I'll see if the firmware update solves this.
01-20-2013, 08:22 AM   #4
Senior Member




Join Date: May 2012
Photos: Gallery
Posts: 140
Slightly off-topic (not flash-related), but I think I've found a way to hang the K-5IIs's OS.

Firmware 1.01 already installed.

In the menu, I set the camera to record the smallest files possible. One-star JPEGs only.

Taking the smallest files possible yields the greatest number of files that may be saved, right?

Everything seemed fine until I closed the menu, and thereby locked it in. The top LCD indicated that I had room on my SD card for 9999 photos — and then it hanged. Needed to remove the battery to regain control.

I guess I invoked a buffer overflow on the remaining photos counter.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, body, built-in, camera, flash, grip, issue, k-5, pentax help, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
issues with K-01 built-in flash dstructor Pentax K-01 11 03-30-2013 11:52 AM
K-5 built-in flash alamo443 Pentax K-5 11 02-10-2013 11:29 AM
K-5iis hangs with in-camera HDR RobG Pentax K-5 16 01-18-2013 05:28 AM
K-5 ii vs K-5 iis comparison with higher sharpness in K-5 ii kataria0 Pentax K-5 62 12-22-2012 10:12 PM
Pentax K-5 hangs when doing digital preview with AF-360 flash DDPhotos Pentax K-5 9 09-20-2012 09:50 AM



All times are GMT -7. The time now is 03:02 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top