Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-29-2013, 07:14 PM   #1
Senior Member
CypherOz's Avatar

Join Date: Sep 2007
Location: Adelaide
Posts: 244
K-5 metering has gone screwwy (fault)

I was out with my K-5 on Sunday, all good until I heard a clunk and the mirror seemed locked up.
I removed the battery and cleared the mirror lock.
Since then the metering has been wrong.
Eg. Av mode Bright sunny day, f/8 ISO 400 and it wants 8 seconds on the shutter speed.

Has anyone had a similar fault?

The camera is about 2 years old and not in warranty.

The local agent (CR Kennedy) advises $27 to quote and at least $160 for a repair (possibly much more).
Australian question: Under consumer law this is reasonable given the nature of the fault?

Should I bite the bullet and get just get a K-5 IIs ??

01-29-2013, 10:58 PM   #2
Pentaxian
Ratmagiclady's Avatar

Join Date: Nov 2008
Location: GA
Photos: Gallery | Albums
Posts: 13,476
QuoteOriginally posted by CypherOz Quote
I was out with my K-5 on Sunday, all good until I heard a clunk and the mirror seemed locked up.
I removed the battery and cleared the mirror lock.
Since then the metering has been wrong.
Eg. Av mode Bright sunny day, f/8 ISO 400 and it wants 8 seconds on the shutter speed.

Has anyone had a similar fault?

The camera is about 2 years old and not in warranty.

The local agent (CR Kennedy) advises $27 to quote and at least $160 for a repair (possibly much more).
Australian question: Under consumer law this is reasonable given the nature of the fault?

Should I bite the bullet and get just get a K-5 IIs ??
Probably needs more information. Tried unmounting and re-mounting the lens? My guess is the initial issue may have been the computer thinking it needed a very long automatic exposure, eight seconds possibly being the maximum there. I'd try perhaps getting in and out of video mode or live-view after freshly restarting: it's possible the issue is either a bad metering cell or the camera behaving as if there were one.

Might reset factory defaults before sending the camera away, at least. At a guess.
01-29-2013, 11:07 PM   #3
Pentaxian




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,284
Does the viewfinder look normal? The metering light path is off the mirror, up into the viewfinder area where part of the light is reflected to the metering hardware. I'd pull the lens off to see if the mirror has come back down into place. It may be a simple repair if there is a mechanical screwup with the mirror.

I would hate to try to talk you out of buying a K5IIs.
01-30-2013, 01:06 AM   #4
Senior Member
CypherOz's Avatar

Join Date: Sep 2007
Location: Adelaide
Posts: 244
Original Poster
Thanks, I'll try those ideas


Last edited by CypherOz; 01-30-2013 at 02:14 AM.
01-30-2013, 02:14 AM   #5
Senior Member
CypherOz's Avatar

Join Date: Sep 2007
Location: Adelaide
Posts: 244
Original Poster
The reset cleared it !!! yay!!! Thanks

Last edited by CypherOz; 01-30-2013 at 03:05 AM.
01-31-2013, 08:09 AM   #6
Site Supporter
Site Supporter
GeneV's Avatar

Join Date: Oct 2008
Location: Albuquerque NM
Photos: Albums
Posts: 9,775
I've had funny issues like that with the mirror locking and the camera not working on some occasions when I have used the cable release on the K-5. Usually taking the battery out solves it.
01-31-2013, 02:43 PM   #7
Senior Member
CypherOz's Avatar

Join Date: Sep 2007
Location: Adelaide
Posts: 244
Original Poster
I've just updated to firmware 1.14 -- seems all ok now
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
fault, k-5, mirror, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 lowest metering limit? UnknownVT Pentax K-5 22 01-07-2013 02:17 PM
K-5 Odd Metering Flub sadatoni Pentax K-5 8 01-01-2013 08:29 AM
My Neighborhood Has Definitely Gone To.... magkelly General Talk 30 06-08-2012 01:22 PM
Help!!!! My K5 has gone nuts. LightSpeed Pentax K-5 7 02-22-2012 12:37 AM
K7 ... where has the metering "bar" gone in manual mode? jpzk Pentax DSLR Discussion 3 06-25-2010 07:26 AM



All times are GMT -7. The time now is 11:54 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top