Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-01-2013, 12:12 PM   #1
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,190
SD card write-protect unremovable?

Weird thing happening with all my SD cards (so I presume it's the laptop I'm using...) - can't copy into them, paste into them, but I can copy from them (cut not also possible).

I try to reformat it in the camera - it does. I try it on my PC - doesn't work. I tried googling and found lots of other people having the same problem, no concrete solution though. Now I can't copy new firmware data into the card..

Anyone encountered this behavior yet? I'm using Windows 7.

02-01-2013, 12:20 PM   #2
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,939
Going on a wild guess, are you trying to muck with the files as a user other than the administrator? It sounds like you have a permission turned off of some sort in regards to the ability to modify the drive letter that the card is assigned to.
02-01-2013, 12:31 PM   #3
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,190
Original Poster
QuoteOriginally posted by Sagitta Quote
It sounds like you have a permission turned off of some sort in regards to the ability to modify the drive letter that the card is assigned to.
I'm the only user of this PC so there are no other user profiles to use. I can't remember when it happened (perhaps after one of the automatic updates) that the logo of the SD card drive changed to one that looks like a card with "SD" on it- thought it was an upgrade of sorts.

Then, I could copy photos from the card to the PC... then I realized I couldn't write into them. What seems to be the problem? also thanks for the quick reply ...
02-01-2013, 12:34 PM   #4
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
Have you tried it on another computer? Still acts the same?

Try and do a system restore to the date before the update you are talking about; and see if it still does the same.
And just for the hell of it ... check your administrator permissions.

02-01-2013, 12:41 PM   #5
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,190
Original Poster
QuoteOriginally posted by mrNewt Quote
And just for the hell of it ... check your administrator permissions.
Will try it on my brother's PC when I get the chance. But as far as admin permissions are concerned, USB devices like flash drives and external drives work fine; just the SD cards won't.
02-01-2013, 12:43 PM   #6
Veteran Member
mrNewt's Avatar

Join Date: Nov 2011
Location: ON, RH
Posts: 2,170
QuoteOriginally posted by Alizarine Quote
Will try it on my brother's PC when I get the chance. But as far as admin permissions are concerned, USB devices like flash drives and external drives work fine; just the SD cards won't.
Btw ... try this:

How to remove write protection from SD card? - Yahoo! Answers
(read the whole thing!!)
02-01-2013, 03:02 PM   #7
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,865
SD cards have a little lever on them, is it in the correct position?
02-01-2013, 09:33 PM   #8
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,190
Original Poster
QuoteOriginally posted by mrNewt Quote
How to remove write protection from SD card? - Yahoo! Answers (read the whole thing!!)
No luck maybe SysRestore is the key..

QuoteOriginally posted by Na Horuk Quote
SD cards have a little lever on them, is it in the correct position?
Yes, I've even tried switching the lever "in-between" in all cards - didn't work also.Could it also be the work of a virus?

04-04-2013, 08:14 PM   #9
Forum Member




Join Date: May 2011
Location: Brisbane
Posts: 88
Yep I got the same problem. Only noticed when I tried to update my firmware today. Formatting works on the camera but attached to the comp its "read only" under disk management.

The tab on the side is set to unlocked. So please don't offer that solutions.

Last edited by MagusAku; 04-04-2013 at 08:23 PM.
04-04-2013, 09:05 PM   #10
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,939
I did some research thinking it was my SD card causing me my EXIF woes (it wasn't) - apparently all SD cards have a notch on the *other* side of the lever. This notch makes the card writable in portable devices, and non-writable on PCs. Its supposed to help combat piracy of music and video as people can't copy that stuff to an SD card and transport it.

The trick is to tape over that notch without having whatever you used to tape it with come loose and gum up your PCs SD slot.
04-05-2013, 06:27 PM   #11
Junior Member




Join Date: Jul 2011
Posts: 41
this is a virus, i have the same problem, in some cases i take off the SD of the computer and put in again and work, or if formar the SD in the camera
04-05-2013, 06:51 PM   #12
Site Supporter
DeepThrob's Avatar

Join Date: Nov 2012
Location: Taos, New Mexico
Posts: 145
I'd try one of those $12 walmarts /targus usb multi-card readers
04-08-2013, 10:23 PM   #13
Veteran Member




Join Date: Dec 2010
Location: Manila
Photos: Gallery | Albums
Posts: 2,190
Original Poster
For some odd reason my cards are working again normally. I don't know when, but I can now cut/paste into and from the card. The "SD" icon is still there when I insert the card, but there's no more "card is write-protected" error

All I remember was un-installing some toolbars in Firefox and cleaning up registry
04-09-2013, 01:37 AM   #14
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 32,762
Glad you got it sorted and got back to full speed ahead on the photography front.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
copy, pentax help, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
PNY Class 10 card inconsistent write speed bwDraco Troubleshooting and Beginner Help 16 07-25-2011 02:21 PM
Crap! My new class 10 sd card run much slower than my old class 4 sd card... liukaitc Pentax Camera and Field Accessories 15 05-31-2011 01:39 PM
Write Protect Tab Broken Off Eye-Fi Pro2 Card Tonto Troubleshooting and Beginner Help 6 04-03-2011 10:18 PM
Scratched SD Card Contacts? Oh, and Don't get pqi SD Cards. AgentFixer Pentax Camera and Field Accessories 4 02-21-2008 09:16 PM



All times are GMT -7. The time now is 09:20 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top