Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-27-2013, 06:53 PM   #1
New Member




Join Date: Feb 2013
Posts: 9
K-5 froze up

A couple of days ago I was out taking some pics in our deep snow with my new K-5, less than a week old and under 100 pictures. It was cool but not cold. I had just taken a series, and went over to another subject and the camera just froze/locked up. I couldn't make any adjustments, and it wouldn't even turn off to reset. I thought perhaps it was too cold so put it in the bag and brought it back into the house. After over an hour it still would not turn off. Finally I removed the battery and when I put it back in everything was back to normal. I have viewed some of the previous threads about this issue, but have not seen any definitive answers on why this occurs. Does anyone have any feedback from Pentax or a repair shop?

02-27-2013, 07:17 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,942
It seems to happen randomly, but fortunately not very frequently. Cold temperature or low battery voltage can make it more likely to occur.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-27-2013, 07:50 PM   #3
Veteran Member
treebeard's Avatar

Join Date: Nov 2008
Location: Windham, NH
Photos: Gallery | Albums
Posts: 795
I had an inexpensive 3d party battery I tried using once and it caused similar issues. I don't use that battery anymore and no more issues.
02-27-2013, 08:17 PM   #4
Banned




Join Date: Feb 2013
Posts: 390
A few years ago, when they first came out, my new K20 started doing the same thing. It was quite random and not very often at first, but as time went by it became more frequent. As it approached the end of the 1yr warranty period I sent it in for repair. They replaced the main board, and I never had the problem again. I'm not saying that's the case here, but you may want to keep this in mind if the freezes start happening more often. The whole repair process took about 2 weeks, including travel time from MA to AZ and back, total time in shop was 2 - 3 days from receipt to re-shipping, IIRC.

02-27-2013, 08:31 PM   #5
New Member




Join Date: Feb 2013
Posts: 9
Original Poster
I checked at this site, the date of manufacture for my camera was just last July. The doubt in my mind is the worst part of it, just not knowing when or if it will happen again. Does anyone know if this has been an issue with the K 30's? I am still within the grace period with Adorama and could return or exchange it.
02-27-2013, 08:53 PM   #6
Pentaxian




Join Date: Jan 2010
Location: Vancouver, BC
Posts: 1,421
If you are having doubts, return it and exchange for a new one. I wouldn't hesitate, there is no point in wondering if the problem will reoccur and it's completely within your rights. I am just never in that position because I never buy anything new.
02-28-2013, 12:06 AM   #7
Pentaxian
EarlVonTapia's Avatar

Join Date: Oct 2012
Location: Vancouver
Photos: Gallery
Posts: 1,150
QuoteOriginally posted by wiley old goat Quote
I checked at this site, the date of manufacture for my camera was just last July. The doubt in my mind is the worst part of it, just not knowing when or if it will happen again. Does anyone know if this has been an issue with the K 30's? I am still within the grace period with Adorama and could return or exchange it.
My k30 has just over 10,000 clicks in about 5 months, and it has become frozen about 5-6 times. The first instance happened around the 5000 click mark. One of those times was due to a crappy memory card, but as for the other times, there was really no rhyme or reason as to why it happened. One time it was just a regular day at the park. One time was when I was playing around with my AF 360 FGZ flash attached to the hotshoe. Once I was just sitting in my room . . .

It doesn't really bother me though. All of my other electronic devices like my laptop and cellphones have their quirks. It's just one of those things where lots of tiny circuits and moving parts = the occasional hiccup.

In conclusion, cameras are weird.

Last edited by EarlVonTapia; 02-28-2013 at 12:11 AM. Reason: grAMer
02-28-2013, 12:10 AM   #8
Pentaxian
EarlVonTapia's Avatar

Join Date: Oct 2012
Location: Vancouver
Photos: Gallery
Posts: 1,150
I should add, my fix in all of those situations was to pull out the battery since none of the buttons, switches, or dials worked. Once I popped it back in there was no more issues until the next freezeup.

Your situation may be different though, since your camera is new. B&H has a less than 200 picture policy for camera returns, so if you're uncomfortable with your K5's freezing, just switch it for another cam (a K5 or K30 or above) before you hit 200 pics. Peace of mind is worth its weight in gold.

EDIT: Nevermind, you got it from Adorama. Advice still applies though.

02-28-2013, 12:39 AM   #9
Banned




Join Date: Jun 2012
Location: NY/Germany
Posts: 1,183
Happened to my K-5 little over a week ago. Shot a couple of raws during a concert, was not cold, was not using a third party battery, late-model manufacture before being discontinued. It just locked with the writing light illuminated. 1.14.

Had to pull the battery. Only lost the last pic it was writing, which wasn't a bit deal, really.
02-28-2013, 11:55 AM   #10
New Member




Join Date: Feb 2013
Posts: 9
Original Poster
Thank you all for your responses, I appreciate knowing that the K-30 also has problems with this issue. I would be interested to hear if Pentax has acknowledged that there is a problem, and if they have any potential solutions. Also it will be interesting to see if this same issue pops up in the K5II and K5IIs.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-5, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 lock-up Lemonhead Pentax K-5 12 07-04-2012 01:30 PM
K-5 froze....why ? lesmore49 Pentax K-5 5 06-04-2012 09:32 AM
K-5 locked up: return or keep? gs18jlll Pentax K-5 13 12-28-2011 01:41 PM
K-7 froze in video mode, now messed up dedmozaj Troubleshooting and Beginner Help 4 05-18-2011 04:26 PM
K-X made clunking, vibrating noise then froze up Olypentax Pentax DSLR Discussion 3 03-11-2010 11:43 AM



All times are GMT -7. The time now is 07:55 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top