Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-09-2013, 09:33 AM   #1
Inactive Account




Join Date: Jan 2011
Location: Midwest
Posts: 106
K200 D Acting Odd

My K200 D is acting very odd. Battery icon indicated low battery power so I replaced all the batteries with new Lithiums as always. Replaced them in the grip and body both. Anyway, it still fluctuates from showing full battery power to half to none.

As far as functions...when I put a Pentax-M lens on, and try to shoot in manual mode, an "F" flashes in the viewfinder, the camera won't shoot and the green button doesn't work...When I put a Pentax-A lens on, and shoot in AV it seems to work ok, but the battery power icon again fluctuates from full to half to none and the I can't shoot on manual mode with the A lens either...With a 40/2.8 XS lens, it focuses and shoots in AV, but the battery icon is still goofed up...Any thoughts on this?

I just used the camera two days ago with no problems.

Thanks.

03-09-2013, 09:51 AM   #2
Site Supporter
slip's Avatar

Join Date: Oct 2006
Location: 2 hours north of toronto ontario canada
Photos: Gallery | Albums
Posts: 3,519
If you turn it off quickly and then back on does the power indicator go to normal? My wife's k100 does this, especially in colder weather.
I find low batteries are the root of a lot of DSLR problems. double check with a new set. as far as the other problems go, if the new batteries don't clear it up, hopefully someone will have the answer for you

good luck

randy
03-09-2013, 09:58 AM   #3
Inactive Account




Join Date: Jan 2011
Location: Midwest
Posts: 106
Original Poster
QuoteOriginally posted by slip Quote
If you turn it off quickly and then back on does the power indicator go to normal? My wife's k100 does this, especially in colder weather.
I find low batteries are the root of a lot of DSLR problems. double check with a new set. as far as the other problems go, if the new batteries don't clear it up, hopefully someone will have the answer for you

good luck

randy
Well, power indicator does not go to normal each time. And when I look at the power of the grip and or body in the menu, sometimes it will show full grip/low body...sometimes empty grip/half body...and with the grip off it's still eratic.
03-09-2013, 11:06 AM   #4
Senior Member
pezmaker's Avatar

Join Date: Jul 2011
Location: Madison, WI
Photos: Gallery | Albums
Posts: 276
Take the grip off - what happens with both sets of batteries in the camera? I have a grip for my K200D, but I never use it - it really screws with the battery metering. I haven't had any of the other symptoms you're describing, but it can't hurt to see what happens with the camera without the grip. Eliminating factors, so to say.

03-09-2013, 11:56 AM   #5
Inactive Account




Join Date: Jan 2011
Location: Midwest
Posts: 106
Original Poster
QuoteOriginally posted by pezmaker Quote
Take the grip off - what happens with both sets of batteries in the camera? I have a grip for my K200D, but I never use it - it really screws with the battery metering. I haven't had any of the other symptoms you're describing, but it can't hurt to see what happens with the camera without the grip. Eliminating factors, so to say.
It acts the same regardless of what configuration I try. With or without grip. I'm going to buy another set of batteries and try that. When I bought this new set last night they were in a different package than normal, and it may be nothing, but, maybe they were old stock...It's worth a try before I go into a histerical crying mode...I can't afford another body and I don't know if it's cost effective to have these repaired.
03-09-2013, 12:05 PM   #6
Senior Member
pezmaker's Avatar

Join Date: Jul 2011
Location: Madison, WI
Photos: Gallery | Albums
Posts: 276
QuoteOriginally posted by topaz Quote
It's worth a try before I go into a histerical crying mode...I can't afford another body
I wish you luck. I'm in similar shoes, if I were to need to put my workhorse down.
03-09-2013, 12:16 PM   #7
Inactive Account




Join Date: Jan 2011
Location: Midwest
Posts: 106
Original Poster
QuoteOriginally posted by pezmaker Quote
I wish you luck. I'm in similar shoes, if I were to need to put my workhorse down.

Thanks.
03-09-2013, 12:58 PM   #8
Inactive Account




Join Date: Jan 2011
Location: Midwest
Posts: 106
Original Poster
Well Geez! I figured out the problem with the manual mode...I'm embarrassed to say that sometime or another, I accidentally turned of the option to allow the use of the aperture ring...What a dingbat!

Don't know when I changed the setting...or why...but it might have been after a session of drinking some adult kool-aid...Still having the battery thing though. But I think I just got a bad batch. Like you all know, these things need plenty of gas to operate.

I'll update later on the battery issue.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
av, battery, camera, half, icon, k200, lens, mode, odd, pentax help, power
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question Quick reply acting as quote Heinrich Lohmann Site Suggestions and Help 2 12-12-2012 11:44 PM
K-7 acting up? voyager13 Troubleshooting and Beginner Help 3 09-25-2012 07:21 PM
Bulb mode acting strange 123jippo Pentax K-5 8 08-06-2012 02:55 AM
K5 Shutter erratically acting strangely. captainbert Pentax K-5 2 05-27-2012 11:13 AM
Pentax battery charger d-bc50 acting strange CWyatt Photographic Technique 1 02-01-2010 03:56 PM



All times are GMT -7. The time now is 10:02 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top