Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-10-2013, 08:33 AM   #1
New Member




Join Date: Apr 2012
Posts: 2
K5 and AF540FGZ problem

I have recently aquired a K5 and find that my AF540FGZ flash only works on "A" automatic mode, no matter how I set the camera or flash. With my old K100 and a friends K5 the flash will work in PTTL, TTl doe etc. When I mount the flash on my K5 in say the "green" mode the flash only shows TTL but won't fire, I need to set the flash onto "A" with the camera in TV to get anything like proper exposure. Is there something in the sub menus I'm missing?

03-29-2013, 02:11 PM   #2
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
It oculd be the lens, if i recall correctly you need a lens with an auto aperture.
03-30-2013, 03:17 AM   #3
New Member




Join Date: Apr 2012
Posts: 2
Original Poster
Thanks for the reply, however the lens isn't the issue as it is auto aperture and the flash works fine with my old K100 using the same lense, that is why I'm thinking it is either something within the "menus" or a fault with the camera. Also tried updating to the latest software for the K5 but that didn't solve the problem either.
03-30-2013, 04:33 AM   #4
Veteran Member
Anvh's Avatar

Join Date: Sep 2011
Posts: 4,616
It's quite strange, i can't even get the Af540 into ttl mode on the K5, it automaticly go to P-TTL.
K5 does not support TTL so there is no reason to be an option for that inside the K5 since it can not use it.

It could be a dirty contact maybe? if not i fear there is more going on

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af540fgz, camera, flash, k5, mode, pentax help, ttl
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random problem with k5 and d fa 100 wr Vindemiatrix Troubleshooting and Beginner Help 5 11-09-2012 04:56 PM
K5 and night Photography Problem nirVaan Pentax K-5 10 05-15-2012 04:24 AM
K5 with A-lens and wireless flash problem glasbak Pentax K-5 8 01-13-2012 06:16 AM
K5 problem and customer service Sifu Pentax K-5 22 12-06-2011 06:08 PM
SR and Livewview Problem w/ Sigma 24-70 DG HSM on K5 :( frank Pentax SLR Lens Discussion 16 08-12-2011 12:40 AM



All times are GMT -7. The time now is 03:59 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top