Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-15-2013, 05:07 PM   #1
Site Supporter




Join Date: Jul 2012
Photos: Gallery | Albums
Posts: 2,774
Two issues with my Pentax SF 1.

I have just received a Pentax SF1. I have two issues.

#1. I am unable to get this unit to load film. I have made sure that I was loading according to the instruction manual. One problem is that the plastic, sprocketed spool to the right of the guide rails is frozen. It will not pull the film into the take-up reel.


#2. The mirror that should be visible when the body cap is removed, is stuck in the up position.
This unit appears to be new, or it has been very well cared for.

Please help.

Thank you,

Tony

03-15-2013, 05:24 PM   #2
Pentaxian




Join Date: Jan 2010
Location: Vancouver, BC
Posts: 1,421
Obvious question, do you have fresh battery?
03-15-2013, 10:45 PM   #3
Site Supporter




Join Date: Jul 2012
Photos: Gallery | Albums
Posts: 2,774
Original Poster
Two issues with my Pentax SF1.

Yes, I used a brand new Duracell 2CR5 battery, good until 2022. Also, the Duracell battery seemed strong enough to allow the motor to pull the film across the guide rails. The film is loaded, however in the LCD Screen it tells me that the film is not loaded properly by displaying a flashing zero.

The second problem still exists. The mirror remains in the up position. There is no adhesive leak from the mirror damper. It seems to be in very good shape. Also, the back support for the mirror folds and unfolds just as it should.

I am thinking perhaps this is coming down to a faulty shutter issue.

Thanks for the suggestions, I do hope this will be an easy fix.

Tony
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
film, issues, pentax, pentax help, unit
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two videos I made with my pentax K-01 minilink Pentax K-01 14 04-02-2013 11:09 AM
Pentax SF-1 & SF-10 kiteman Pentax Film SLR Discussion 10 12-12-2012 11:12 AM
MAJOR issues with my K5!! Senseriffic Pentax K-5 21 12-11-2012 09:10 AM
issues with my k1000 elevatormusic Troubleshooting and Beginner Help 8 12-02-2011 09:17 PM
For Sale - Sold: Pentax Flagship Camera SF1 SF-1 Body with Body Cap, Battery, and Original Manu yyyzzz Sold Items 6 03-15-2010 11:54 PM



All times are GMT -7. The time now is 07:29 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top