Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-20-2013, 02:05 PM   #16
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
5:30 on the clock, so at the bottom of the circle -- in your picture just to the right of the flash glare and left of the screw.

03-20-2013, 02:08 PM   #17
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by vonBaloney Quote
5:30 on the clock, so at the bottom of the circle -- in your picture just to the right of the flash glare and left of the screw.
IT WORKED :-D - but I just cannot get it why it mounts with this pin on K5IIs and K30 and not on K-01......but I pushed it in and it worked - gonna ask my camera shop guys to remove it just in case.

Thanks a million guys - it's awsome to see it resolved with your help - hope I can repay it someday
03-20-2013, 02:10 PM   #18
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
QuoteOriginally posted by geirix Quote
IT WORKED :-D - but I just cannot get it why it mounts with this pin on K5IIs and K30 and not on K-01......but I pushed it in and it worked - gonna ask my camera shop guys to remove it just in case.

Thanks a million guys - it's awsome to see it resolved with your help - hope I can repay it someday
Most likely because the screw-drive recesses on the K-01 (when in MF mode), whereas it always sticks out on the others. You're lucky it didn't get stuck on one of them. Don't mount it again until you get that thing off...
03-20-2013, 02:11 PM   #19
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by vonBaloney Quote
Most likely because the screw-drive recesses on the K-01 (when in MF mode), whereas it always sticks out on the others. You're lucky it didn't get stuck on one of them. Don't mount it again until you get that thing off...

I won't - gonna look out for this Rioch screw in the future when I buy an old quality lens for a lot - just to be safe.

03-20-2013, 02:14 PM   #20
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
QuoteOriginally posted by geirix Quote
I won't - gonna look out for this Rioch screw in the future when I buy an old quality lens for a lot - just to be safe.
Also look out for the big shield they shaved off (unneccesarily in this case I think) -- sometimes they actually are too big (old Vivitars in particular).
03-20-2013, 02:16 PM   #21
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by vonBaloney Quote
Also look out for the big shield they shaved off (unneccesarily in this case I think) -- sometimes they actually are too big (old Vivitars in particular).
Yeah - i'll look out for that vonBaloney - i'm gonna sit in the repairshop with the guys and see how the pin is removed - although i've learned to rip apart small electronics and assemble them again - i've never ventured into cameras - perhaps it's time to learn aswell with help of some good people and get the knowlegde out of it out to those who need it
03-20-2013, 02:23 PM   #22
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 4,989
QuoteOriginally posted by geirix Quote
Yeah - i'll look out for that vonBaloney - i'm gonna sit in the repairshop with the guys and see how the pin is removed - although i've learned to rip apart small electronics and assemble them again - i've never ventured into cameras - perhaps it's time to learn aswell with help of some good people and get the knowlegde out of it out to those who need it
I've yanked them out with needle-nose pliers and it was fine, but not with a lens I've paid a small fortune for...
03-20-2013, 02:40 PM   #23
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
Well, I found this - theatre of noise: Ricoh Lenses On Pentax Cameras -- The Ricoh Pin Fix

Followed it to the letter and removed the pin and it's WORKING

Sent the camera store guys the link just in case so this won't be a mystery if someone else has that same prob.

03-20-2013, 03:09 PM   #24
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
Excellent! PF Member comes to the rescue again!
03-20-2013, 03:57 PM   #25
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
Of course - the Pentax community is the best ;-)
03-20-2013, 05:10 PM   #26
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,696
Usually the Ricoh pin problems stops you getting the lens off.

I've never heard it work this round before, as in can't get the lens on, I guess of the two, this is the best way to be.
03-20-2013, 05:23 PM   #27
Site Supporter




Join Date: Sep 2011
Location: Calgary
Photos: Albums
Posts: 101
lens doesn't lock

Howdy! I had this problem with a lens too! So I pushed the "ricoh pin " in and tried it on the K5. It now locks! Yippee!

Also -thanks for the link to the removal of the pin, but is there any other way to get the pin out without taking out the screws.


Liz in Calgary
03-20-2013, 05:38 PM   #28
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by kerrowdown Quote
Usually the Ricoh pin problems stops you getting the lens off.

I've never heard it work this round before, as in can't get the lens on, I guess of the two, this is the best way to be.
True, true. But the K-01 is different in so many ways - why not this way too?
03-20-2013, 05:53 PM - 1 Like   #29
Pentaxian
Sagitta's Avatar

Join Date: Feb 2011
Location: Maine
Photos: Gallery
Posts: 2,912
QuoteOriginally posted by Liz_in_Calgary Quote
Howdy! I had this problem with a lens too! So I pushed the "ricoh pin " in and tried it on the K5. It now locks! Yippee!

Also -thanks for the link to the removal of the pin, but is there any other way to get the pin out without taking out the screws.


Liz in Calgary
Not really. I suppose you could just needlenose-rip the thing out, but that seems a lot more destructive than unscrewing the mount.

It really is a simple job as long as you're careful about it. I bought a handful of old Sears lenses online that came with the pins - I went to Walmart and spent about $15 on a screwdriver set and a magnetic dish to put the screws in and managed to do all three in maybe a half hour - and that was with distractions added in.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-01, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noob question: Should any K-mount AF lens work on K-01? harioharima Pentax K-01 3 02-12-2013 03:14 PM
Old K mount lens won't fit on my k-r body Timelime Troubleshooting and Beginner Help 10 02-10-2013 01:02 PM
My K5 shutter doesn't work with K mount M 50mm 1.7 MikeD Pentax SLR Lens Discussion 13 12-13-2012 01:24 PM
K-01 doesn't feel as cheap as it looks! hands-on video... JohnBee Pentax K-01 15 02-10-2012 08:14 AM
what to do if 1.01 doesn't fix MLU hotpixels on K20D? kenyee Pentax DSLR Discussion 6 01-08-2009 09:28 AM



All times are GMT -7. The time now is 07:27 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top