Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-20-2013, 11:12 AM   #1
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Lens doesn't mount on K-01

Got kind of a weird problem. Got a Cosina 28mm f/2.8 lens with PK mount - it mounts fine on K5IIs and K1000 film camera - but when I try to mount it on my K-01 it just doesn't.

Any ideas why that might happen?

03-20-2013, 12:38 PM   #2
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
How is it not fitting? Is it sticking? Not turning? Not inserting?
03-20-2013, 12:39 PM   #3
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
It fits - but it won't go all the way to lock in place....i've never seen that happen - it is turning, just not all the way.
03-20-2013, 01:10 PM   #4
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,885
Is the shield that protects the aperture stop-down lever too large by any chance? Third-party lenses do not all have the right shape of this part.

03-20-2013, 01:12 PM   #5
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
Is it set at infinity? Does it fit if you focus to the closest distance?
03-20-2013, 01:13 PM   #6
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by Ole Quote
Is the shield that protects the aperture stop-down lever too large by any chance? Third-party lenses do not all have the right shape of this part.
Well, my camera store guys thought so too - so they "shaved" it a bit but still no luck. Just doesn't lock in place.......i'm lost at what to do since I spent a small fortune on the lens to use with the K-01.
03-20-2013, 01:15 PM   #7
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by vonBaloney Quote
Is it set at infinity? Does it fit if you focus to the closest distance?
Nope, doesn't fit no matter what - it just doesn't go the small extra mile to lock in place.
03-20-2013, 01:23 PM   #8
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
Photo of the mount?

03-20-2013, 01:32 PM   #9
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster


Here is a view of the mount after "shave" - both camera shop experts couldn't see why it should not fit the K-01 since it did fit K30 and K5 IIs and K1000 ......

Last edited by geirix; 03-20-2013 at 01:40 PM.
03-20-2013, 01:40 PM   #10
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
...and for some reson the photo doesn't show up...here is the url for it -> http://www.geirix.com/Geirix_20130320_20_24_59_Pressphotos_.jpg
03-20-2013, 01:43 PM   #11
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by geirix Quote
...and for some reson the photo doesn't show up...here is the url for it -> http://www.geirix.com/Geirix_20130320_20_24_59_Pressphotos_.jpg
It's there now.
03-20-2013, 01:51 PM - 1 Like   #12
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
Looks like a "ricoh" pin in the 5:30 position -- is that a hard pin or a little spring button?
03-20-2013, 01:52 PM   #13
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by vonBaloney Quote
Looks like a "ricoh" pin in the 5:30 position -- is that a hard pin or a little spring button?

Well - allt the small pins are spring buttons.....
03-20-2013, 02:00 PM   #14
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by geirix Quote
Well - allt the small pins are spring buttons.....
But that particular one is for Ricoh (film) cameras and not Pentax cameras. Sometimes it is a pin that causes lenses to get stuck -- usually they prevent dismounting rather than mounting. But I think it is your problem -- getting hung up on the AF screw drive (which is recessed if in MF mode on the K-01). Remove that pin/button -- you don't need it anyway.
03-20-2013, 02:01 PM   #15
Forum Member
geirix's Avatar

Join Date: Jan 2013
Location: Reykjavik
Photos: Gallery
Posts: 58
Original Poster
QuoteOriginally posted by vonBaloney Quote
But that particular one is for Ricoh (film) cameras and not Pentax cameras. Sometimes it is a pin that causes lenses to get stuck -- usually they prevent dismounting rather than mounting. But I think it is your problem -- getting hung up on the AF screw drive (which is recessed in the K-01 but not in the others). Remove that pin/button -- you don't need it anyway.
Ok - at 5:30 - which one is it - number 1, 2, 3,... ???
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-01, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Noob question: Should any K-mount AF lens work on K-01? harioharima Pentax K-01 3 02-12-2013 03:14 PM
Old K mount lens won't fit on my k-r body Timelime Troubleshooting and Beginner Help 10 02-10-2013 01:02 PM
My K5 shutter doesn't work with K mount M 50mm 1.7 MikeD Pentax SLR Lens Discussion 13 12-13-2012 01:24 PM
K-01 doesn't feel as cheap as it looks! hands-on video... JohnBee Pentax K-01 15 02-10-2012 08:14 AM
what to do if 1.01 doesn't fix MLU hotpixels on K20D? kenyee Pentax DSLR Discussion 6 01-08-2009 09:28 AM



All times are GMT -7. The time now is 05:06 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top