Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-24-2013, 06:09 PM   #16
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,284
AFAIK the lens ID is in the "Maker Notes" section of the jpeg, which is not standard and the software has to be updated to understand how the maker has stored the info. The DNG however is standard so it makes sense that the software can read the lens codes from there.

No k-30 here so I can't help with testing but it sounds as if the k-30 jpeg EXIF has a change from others. At least you know the camera is not malfunctioning.

You should be able to see the maker notes section in Exiftool and you might be able to see what has changed if you have an older jpeg. You can also add the correct lens ID from within ExifTool. I do this (when I have time) for my Takumars. You have to put the name you want in the LensModel field rather than in the Maker Notes section but it works.

03-24-2013, 06:39 PM   #17
Senior Member




Join Date: Sep 2011
Location: New Hampshire
Posts: 107
QuoteOriginally posted by jatrax Quote
AFAIK the lens ID is in the "Maker Notes" section of the jpeg, which is not standard and the software has to be updated to understand how the maker has stored the info. The DNG however is standard so it makes sense that the software can read the lens codes from there.

No k-30 here so I can't help with testing but it sounds as if the k-30 jpeg EXIF has a change from others. At least you know the camera is not malfunctioning.

You should be able to see the maker notes section in Exiftool and you might be able to see what has changed if you have an older jpeg. You can also add the correct lens ID from within ExifTool. I do this (when I have time) for my Takumars. You have to put the name you want in the LensModel field rather than in the Maker Notes section but it works.
When I say, shows no lens Exif data, I mean it just doesn't show which lens I used. f stop, focal length, shutter speed, etc is all there, just not which actual lens I had on the camera.
03-24-2013, 06:43 PM   #18
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,424
QuoteOriginally posted by New Englander Quote
When I say, shows no lens Exif data, I mean it just doesn't show which lens I used. f stop, focal length, shutter speed, etc is all there, just not which actual lens I had on the camera.
I'm no help with your issue, but just yesterday I mentioned to another member we should be able to enter the lens name just like AF corrections. I have a couple lens that register as ---.
03-24-2013, 07:03 PM   #19
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,284
QuoteOriginally posted by New Englander Quote
When I say, shows no lens Exif data, I mean it just doesn't show which lens I used. f stop, focal length, shutter speed, etc is all there, just not which actual lens I had on the camera.
The lens information is recorded as an ID number like "03 19" or similar. The actual name of the lens is not recorded in the EXIF, the software is supposed to convert the ID to the lens name.

03-24-2013, 07:12 PM   #20
Site Supporter
patrick9's Avatar

Join Date: Feb 2011
Location: Murfreesboro Tennessee
Photos: Gallery | Albums
Posts: 3,279
You got me to wondering so I checked.
I am running silkypix 4.10 My K-30 Exif file reads my FA fully, My DA fully, and A35-80 as A lens. None of my M lenses are reading anything but - - - -. It also only reads the info in JPEG and not RAW
In Photome it only reads the lens in RAW no lens info in the JPEG's. They are all correct even the M lens reads as a K or M lens.
In Elements no lens info in RAW nor JPEG.
03-25-2013, 06:23 AM   #21
Forum Member




Join Date: Feb 2009
Location: Canada
Posts: 58
QuoteOriginally posted by Ole Quote
But it doesn't show the lens name in the case of a K-5 with the DA 560mm. So Adobe hasn't updated Photoshop yet to know about that brand new lens.
ExifTool doesn't know about this lens yet either. Could you please send me an out-of-camera sample image so I can add this lens? My email is phil at owl.phy.queensu.ca ... thanks!

- Phil Harvey (ExifTool author)
07-16-2014, 12:48 AM   #22
New Member




Join Date: Jul 2014
Posts: 1
Not K-30 but possibly Picasa issue

FYI just in case you haven't resolved this issue. I just noticed that after viewing some photos in Picasa (latest version 3.9xx, Windows 7 as of 7/14/2014), the EXIFS reported by Picasa have been mangled and replaced by Exifs from other shots with a D700. However .. .the original jpgs still show the correct Exif (as reported by iRfanview). I mention this because I have also experienced Picasa mangling the actual jpgs a couple years ago.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, data, dng, exif, issue, jpg, lens, pentax help, thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
O-GPS1 and your EXIF data - When the GPS is on, it strips data from the EXIF? Sagitta Troubleshooting and Beginner Help 17 11-23-2016 02:25 AM
K-30 and EXIF Zafar Iqbal Troubleshooting and Beginner Help 7 01-12-2013 07:31 PM
K-30 EXIF/MetaData Offset? UnknownVT Pentax K-30 & K-50 10 11-02-2012 11:28 AM
Question EXIF data Cee Cee Site Suggestions and Help 3 11-18-2011 06:52 PM
K-7, continuous shooting, EXIF data, ... hcc Pentax DSLR Discussion 7 06-17-2010 08:01 PM



All times are GMT -7. The time now is 10:25 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top