Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-06-2013, 04:55 PM   #1
Forum Member




Join Date: Oct 2009
Location: Alberta
Posts: 62
K-5 rear display stopped working

The rear display quit working today while using my K-5. I can't see menus or info, can't review photos, can't use LV, etc. I have tried removing the battery, changed batteries, changed lenses, etc..but I can't get the display to work. I really don't want to jump to the conclusion that the display has died, so I have been searching to see if anyone else has had similar issues. Has anyone else had an issue like this? Is there a quick and easy fix or any suggestions that anyone might have?

Thanks.

04-06-2013, 05:13 PM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,285
Probably a long shot but try pressing the info button several times. I believe that toggles the rear screen off as part of it's cycle. If that does not help, I am afraid you may be looking at a repair call.
04-06-2013, 05:35 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,949
QuoteOriginally posted by nbu Quote
The rear display quit working today while using my K-5. I can't see menus or info, can't review photos, can't use LV, etc. I have tried removing the battery, changed batteries, changed lenses, etc..but I can't get the display to work. I really don't want to jump to the conclusion that the display has died, so I have been searching to see if anyone else has had similar issues. Has anyone else had an issue like this? Is there a quick and easy fix or any suggestions that anyone might have?

Thanks.
Sometimes the display unplugs itself inside the camera. If so, it's a fairly easy DIY fix if you're comfortable with opening up your camera. If you're still covered by warranty, though, I'd just send the camera in.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-06-2013, 05:45 PM   #4
Veteran Member
chromo's Avatar

Join Date: Feb 2010
Location: North Coast NSW
Photos: Gallery | Albums
Posts: 563
Hold the menu button while turning on the camera. it should display the firmware version on the screen.
You can also connect the K-5 to your TV using the video cable to see what should be displayed on the screen. That way you can look around the menu.

It does sound like a repair job though.

04-06-2013, 05:48 PM   #5
Veteran Member
chromo's Avatar

Join Date: Feb 2010
Location: North Coast NSW
Photos: Gallery | Albums
Posts: 563
QuoteOriginally posted by Adam Quote
Sometimes the display unplugs itself inside the camera. If so, it's a fairly easy DIY fix if you're comfortable with opening up your camera. If you're still covered by warranty, though, I'd just send the camera in.
That's interesting Adam.
Do you have a link for that repair ?
04-06-2013, 05:53 PM   #6
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,949
QuoteOriginally posted by chromo Quote
That's interesting Adam.
Do you have a link for that repair ?
No, but I remember reading a thread about it, so it must be here somewhere!

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-06-2013, 06:27 PM   #7
nbu
Forum Member




Join Date: Oct 2009
Location: Alberta
Posts: 62
Original Poster
Thanks for the suggestions. Unfortunately the display still isn't working. When I hook the camera up to the TV, I can see everything that should be on the camera's display, but unfortunately lugging around a TV kinda defeats the purpose of such a nice small DSLR body. LOL

I already sent my K-5 away for repairs 3 times for a total of 11 weeks during the 2 year warranty period, and I'm now about 5 months past the warranty period and am dreading the thought of having to send it in again. I can't afford another camera body or a hefty repair bill, so I might have to try and attempt a DYI repair.
04-06-2013, 08:02 PM   #8
New Member




Join Date: Feb 2010
Location: Twin Cities
Posts: 1
QuoteOriginally posted by nbu Quote
The rear display quit working today while using my K-5. I can't see menus or info, can't review photos, can't use LV, etc. I have tried removing the battery, changed batteries, changed lenses, etc..but I can't get the display to work. I really don't want to jump to the conclusion that the display has died, so I have been searching to see if anyone else has had similar issues. Has anyone else had an issue like this? Is there a quick and easy fix or any suggestions that anyone might have?

Thanks.
I just started having this problem and it turns out to be somehow related to the memory card. It's happened twice and I haven't figured out what the issue is. Take a look at other posts - search K-5 memory card errors. Very annoying.

04-06-2013, 08:18 PM   #9
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,482
Have you tried to reset the camera? Take out the battery overnight. Recharge it fully and re-start the camera.

If it does not works, I would follow Adam/s suggestion: search the forum for a relevant DIY repair.
04-07-2013, 01:15 AM - 1 Like   #10
Senior Member
Patajac's Avatar

Join Date: Jan 2012
Posts: 241
if memory card door is open the display is off. so check there
04-07-2013, 02:24 AM   #11
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,585
QuoteOriginally posted by Patajac Quote
if memory card door is open the display is off. so check there
That's a good heads up, didn't know that one.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
display, k-5, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-30 "Okay" Button Stopped Working lawsonstone Pentax K-30 & K-50 12 11-19-2012 07:40 AM
ZX-5 - AF stopped working all of a sudden dgaies Pentax Film SLR Discussion 11 08-11-2011 05:33 PM
Optio P80 stopped working after... Bgeeker Troubleshooting and Beginner Help 3 05-02-2011 08:04 PM
Optio w90 stopped working bojanstare Troubleshooting and Beginner Help 3 04-18-2011 05:38 PM
K10 rear e-dial stopped working ryan s Pentax DSLR Discussion 5 03-10-2008 03:37 PM



All times are GMT -7. The time now is 01:56 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top