Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-22-2013, 05:53 AM   #1
New Member




Join Date: Jun 2012
Posts: 7
k-5 II and AF on DA 55-300mm Zoom Lens

Hi there

Hopefully somebody will be able to help me. When I use my DA 55-300mm Zoom Lens on the K-5 II, the autofocus keeps on hunting without being able to focus when taking a picture through the viewfinder. Strangely, if I use «LiveView», the lens works as it should be.

If I use this same lens on my Kr, everything's perfect and if I use another lens on the K-5 II (DA 18-135mm WR), everything's perfect as well...

Thanks in advance for any help/hints you can offer. I was trying to shoot sports this weekend but couldn't use this lens

04-22-2013, 06:14 AM   #2
Forum Member
PLC3's Avatar

Join Date: Feb 2013
Location: Berlin
Posts: 52
I don"t really have an explanation as to why this is happening but do you experience this behaviour in 100% of the shots you tried or just in some? I noticed it helps a lot with the 55-300, if you manually move focus close to being right and let the autofocus do the rest, especially if the image is completely out of focus (like when you move from a very close to a far away subject).
04-22-2013, 06:25 AM   #3
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
What focus mode are you using? Did you turn on expanded AF?
04-22-2013, 07:04 AM   #4
New Member




Join Date: Jun 2012
Posts: 7
Original Poster
Indeed, the focus «catches» sometimes in really bright conditions and at the shortest focal length. I tried both AF.s and AF.C and Expanded AF is turned on.

04-22-2013, 07:13 AM   #5
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
What subjects? Any subjects? Do you have any example images where it locked focus (whether accurately or not)?
04-22-2013, 07:25 AM   #6
New Member




Join Date: Jun 2012
Posts: 7
Original Poster
Any subjects. Here's one at 55mm where the AF «caught» on the white border of the window, but could not on the brick wall. At 300mm it wouldn't focus on anything at all...
04-22-2013, 08:11 AM   #7
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,148
The 55-300 is a "slow" lens. At 300 mm your aperture is at f/5.8 and you are at the limits of the AF module's abilities. I wonder if the front/back focus adjustment could help the lens focus a bit better. I don't have that capability with the K10d, but it might enhance the contrast a bit.

Some ideas (that others will probably shoot down, but it won't be the first, nor the last, time).
- Remove any filters on the front of the lens.
- Always, always, always use a lens hood
- Shade the lens with your hand if the hood isn't enough (at the long end, it isn't)

Good luck.
04-22-2013, 09:01 AM   #8
New Member




Join Date: Jun 2012
Posts: 7
Original Poster
Thanks all for your input. I've just been able to test the k-5 II with a friend's 55-300 lens identical to mine and the problem did not occur... I'll send my lens to Pentax today. Why it works on the Kr though is a mystery...

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
55-300mm, da, da 55-300mm, ii, k-5, k-5 ii, lens, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 II and K-30 do not Share the Same AF Module Class A Pentax DSLR Discussion 8 09-19-2012 11:02 PM
For Sale - Sold: Pentax DA 4-5.8 55-300 Zoom Lens doch4m Sold Items 2 02-17-2012 05:44 PM
For Sale - Sold: Pentax DA 55-300mm f/4-5.8 ED Zoom Lens (CONUS) les3547 Sold Items 3 03-19-2011 07:56 AM
Any info on Sigma Zoom AF 70-300mm f4.5-5.6? EsBee Pentax SLR Lens Discussion 3 05-30-2009 11:53 AM



All times are GMT -7. The time now is 07:05 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top