Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-28-2013, 11:54 AM   #1
Senior Member
delegopa's Avatar

Join Date: Apr 2013
Posts: 244
K-30 display turns off after capture

I recently received my K-30 and am really happy with it.

One thing that irritates me is that the display turns off approximately 3 seconds after capturing. So far I found no Setting to adjust this behavior. Therefore it feels more like a bug then a feature.
Is this normal or a known issue? I found nothing concerning this.

Edit: This happens with Firmware Version 1.00 as well as 1.04 when working with the viewfinder.


Last edited by delegopa; 04-28-2013 at 12:00 PM.
04-28-2013, 11:56 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,957
Look for a setting that controls the instant review time. You can configure it for 0 to 5 seconds I believe.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

04-28-2013, 12:16 PM   #3
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,511
Page 212 of the owners manual - 1-3-5 secs or off are the choices.
04-28-2013, 12:21 PM   #4
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,323
I think if you press the info button a couple of times it turns off the display and a function of this is that after a photo is taken, the display turns off after the review. And the review is something you decide in the menu. So you can have a couple seconds or none at all. You can always press the blue play button to review all images on the card.

04-28-2013, 12:23 PM   #5
Senior Member
delegopa's Avatar

Join Date: Apr 2013
Posts: 244
Original Poster
Should have been more precise:
This was described without instant review (which works correct). The statusdisplay shown usually before and after capture turns off.

Capture -> (instant review) -> statusdisplay -3s-> display turns off
04-29-2013, 12:34 AM   #6
Senior Member
delegopa's Avatar

Join Date: Apr 2013
Posts: 244
Original Poster
Found the manual page concerning this (p. 23 EN / p. 25 GER).
It states that this behavior is normal. The status screen will be shown for 2 secs. after capturing and then turn off.
I think I can live with it but still find it unusual that there is no way of changing this.

Thanks for your efforts
04-29-2013, 12:56 AM   #7
Site Supporter
altopiet's Avatar

Join Date: Sep 2010
Location: The Great Karoo, South Africa
Photos: Gallery | Albums
Posts: 1,915
Any use of the back screen drains the battery faster. I believe 2 sec is enough time to check your settings, ISO, Shutter speed and aperture at a glance. The few instances when I want to check it again, I just half press the shutter button and have another look, it then stays on for about 15-20 sec I think
05-10-2013, 03:52 AM   #8
Senior Member




Join Date: Jan 2009
Location: Watertown, NY
Posts: 267
I have my screen set to off in order to save battery life, so I get no instant review.
If for some reason I want to review the photo (s) all I need do is press the playback button (under the AE-L button).

I normally only check the first shot to ensure proper exposure and WB, unless of course the shooting environment changes.

I've shot long enough to trust that the exposure and etc that I set is right. It was difficult at first (not peaking) but with time
I seldom use the instant view feature.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, k-30, pentax help, photography
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Optio RZ18 turns off tan38 Troubleshooting and Beginner Help 3 07-03-2013 09:32 PM
K-30 Synching 32khz audio with external audio capture devices at other sample rate utrechtnl Video and Pentax HDSLRs 2 02-22-2013 05:30 PM
K-30 Live View display in M mode Ronnie B Troubleshooting and Beginner Help 2 01-14-2013 04:07 PM
K-30 on display at Melbourne Digital Show Paul Ewins Pentax K-30 & K-50 10 06-04-2012 07:18 AM
K-7 starts then immediately turns off wjax Pentax DSLR Discussion 9 09-19-2010 03:47 PM



All times are GMT -7. The time now is 07:31 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top