Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-28-2013, 03:23 PM   #1
New Member




Join Date: Apr 2013
Posts: 5
problem with K-7 AF

My K-7 camera's AF function appears to have stopped working. Here is what it is doing...

When I have it on AF.S when I depress the shutter button halfway to focus the lens spins out and back and fails to focus. If I put it to MF I can manual focus, however the green indicator light and beep doesn't work to say when you get focused properly. Also when you try to focus with the flash popped up the red focusing light does not come on.

Any ideas what might have happened to my auto focus? I have tried a different lens and it's the same symptoms.

Thanks
Lorrie

04-28-2013, 06:36 PM   #2
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,142
Unfortunately that sounds like a failed AF module. Before you panic, though, carefully clean all the lens and body mount contacts. If you are lucky the problem is dirty contacts.
04-29-2013, 12:53 AM   #3
New Member




Join Date: Apr 2013
Posts: 5
Original Poster
Unfortunately I have cleaned lens and contacts, this did not help.
04-29-2013, 01:06 AM   #4
New Member




Join Date: Apr 2013
Posts: 5
Original Poster
If this is a failed module, is this a costly repair?

04-29-2013, 08:13 AM   #5
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,142
QuoteOriginally posted by Lorrie61 Quote
If this is a failed module, is this a costly repair?
Yes, unfortunately. You might find it about the same amount to get a used K7 from the marketplace here.
04-29-2013, 07:33 PM   #6
Veteran Member
AndrewG NY's Avatar

Join Date: Dec 2006
Location: Chappaqua, NY
Photos: Gallery
Posts: 676
Considering the potential expense and hassle, you might try resetting all settings to factory defaults. Can't hurt.

Not to suggest this as a viable workaround, but I assume that contrast-detect AF in live view still works fine?

Also, by 'red focusing light' I guess you mean the green LED focus assist lamp? I would actually suspect this *might* come on because it usually lights when camera is struggling to focus. Also, K-7 doesn't need flash popped up for AF assist, the LED lamp is on the front of the body.
04-29-2013, 11:57 PM   #7
New Member




Join Date: Apr 2013
Posts: 5
Original Poster
I already tried to reset - it did not help. In the tools menu page 3, there was a reset option and I did that. Is there another method to reset all to factory defaults?

I rarely ever use live view so I had to check to see if this is working, and yes, live view focusing using the AF button appears to work fine. I even get the audible beep when it's in focus. The green assist light also works in this mode (yes green not red, my bad). However shooting this way is horrible, and I never use it. (the green light does NOT come on at all when trying to shoot out of live view)

Sorry for the confusion what I meant to say rather than the flash up, was low light conditions, and I got confised about the color, not sure why I was thinking red.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, focus, k-7, lens, light, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with K-01 and AF Lens geezer52 Pentax K-01 8 12-26-2012 07:49 AM
K-x with DA 40mm -- AF problem love_myenla Pentax DSLR Discussion 24 12-20-2012 02:45 PM
Problem setting exposure with K-7 sceadgugenga Pentax DSLR Discussion 7 10-14-2010 02:33 AM
Video problem with new K-7 ddbarchitect Video and Pentax HDSLRs 9 06-09-2010 07:46 AM
K-7 ,happy customer with a small problem:( Alefone Pentax DSLR Discussion 11 07-28-2009 07:28 AM



All times are GMT -7. The time now is 02:46 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top