Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-28-2013, 03:54 PM   #1
New Member




Join Date: Apr 2013
Posts: 2
Problems with the power SW, K20D

Hi guys!

I was on holiday in Ireland last year, and my camera fell down from a chair to the hardwood floor. It was in my rucksack, and a chair isn't that tall, but it did somehow damage the camera.

I can't turn it on, but the LED blinks when I put an SD card in, so it does get power, pointing the problem towards something like a soldering for the power SW. However, I opened the camera today, and there is no direct soldering for the power SW on the upper right flex board, which is as far I dared to go as I couldn't discharge the capacitor for the flash.

Now, after I had it opened, I discovered something. When I hold the switch between on and the aperture mark (dunno the name for that mode, sorry), it gets power for a split second, then turns off, then on again. I verified this wasn't some weird way to test the LCD, I could actually change the shutter speed and aperture when doing this. I could not take pictures or get the LCD on.

But atleast, there is still life in my camera, and there is a way to fix it, I am sure of it. A repair costs me 3500NOK, which is around 350, maybe 450$. My insurance wants 4000NOK, and a used camera costs 2500NOK. So no point in repairing it unless I can discover the issue and fix it myself, or get someone professional to solder the cable or whatever.

Anyways, hope you guys might have some input to my issue!

Jim, Norway

04-28-2013, 04:57 PM   #2
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,065
QuoteOriginally posted by Jakke Quote
Hi guys!

I was on holiday in Ireland last year, and my camera fell down from a chair to the hardwood floor. It was in my rucksack, and a chair isn't that tall, but it did somehow damage the camera.

I can't turn it on, but the LED blinks when I put an SD card in, so it does get power, pointing the problem towards something like a soldering for the power SW. However, I opened the camera today, and there is no direct soldering for the power SW on the upper right flex board, which is as far I dared to go as I couldn't discharge the capacitor for the flash.

Now, after I had it opened, I discovered something. When I hold the switch between on and the aperture mark (dunno the name for that mode, sorry), it gets power for a split second, then turns off, then on again. I verified this wasn't some weird way to test the LCD, I could actually change the shutter speed and aperture when doing this. I could not take pictures or get the LCD on.

But atleast, there is still life in my camera, and there is a way to fix it, I am sure of it. A repair costs me 3500NOK, which is around 350, maybe 450$. My insurance wants 4000NOK, and a used camera costs 2500NOK. So no point in repairing it unless I can discover the issue and fix it myself, or get someone professional to solder the cable or whatever.

Anyways, hope you guys might have some input to my issue!

Jim, Norway
Sure sounds like a trip to the shop is in order, short of that...look around Pentaxhacks, Downloads, might find some info there.
04-28-2013, 05:03 PM   #3
New Member




Join Date: Apr 2013
Posts: 2
Original Poster
Lol didnt get to reply till a mod approved my post.

It was the metal fingers on the power sw. Got a hunch after reading about similar problems, and took the top off a second time. There she was!
04-28-2013, 05:12 PM   #4
Site Supporter
Ex Finn.'s Avatar

Join Date: Nov 2007
Location: Southern Maryland.
Photos: Gallery | Albums
Posts: 6,065
QuoteOriginally posted by Jakke Quote
Lol didnt get to reply till a mod approved my post.

It was the metal fingers on the power sw. Got a hunch after reading about similar problems, and took the top off a second time. There she was!
Great, an easy fix.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, camera, chair, costs, guys, issue, lcd, pentax help, power, sw
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Focus stacking with special hw Stack Shot and sw Zerene Sten Pentax K-5 50 11-28-2013 09:53 AM
Anybody with mirror problems with K30? Focus problems. simbon4o Pentax K-30 & K-50 14 08-28-2013 10:39 PM
Pentax KX power problems bcat Troubleshooting and Beginner Help 8 12-06-2012 08:42 PM
How to power 540FGZ flash with Alienbees Vagabond mini II portable power? shadowbecomeswhite Flashes, Lighting, and Studio 2 07-25-2011 07:17 PM
Are dust problems on the K20d sensor typical? Historicity Troubleshooting and Beginner Help 17 06-11-2011 02:02 PM



All times are GMT -7. The time now is 04:59 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top