Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-05-2013, 12:37 PM   #1
New Member




Join Date: May 2013
Posts: 2
K30 looses picture after switch off

Hi everybody!

I bought a K30 yesterday and made some testfotos today. Now I'm a little bit astonished of this phenomenon:

I take one or more pictures, wait till the cam is ready to shoot again and turn it off after a view secondes. (I did this for years with my k100d without problems and I think this is a normal situation.)
But the K30 does not store the last picture in this case (Filesize always 0 kb). I must wait a couple of seconds befor the picture ist saved and I can turn off the cam.
But this is very annoying.
The SD-Card is new, Class 10, very fast and works very well on PC and K30. So i ask myself:

Is this normal for the K30? Does an firmware update help (installed version is v1.00)? Or have you any other ideas?

Thanks and greetings from Germany,
Smurf

05-05-2013, 12:43 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,275
Format your card in camera and that should fix it.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-05-2013, 02:55 PM   #3
New Member




Join Date: May 2013
Posts: 2
Original Poster
Wow, you are realy quick, thank you! But formating didn't help. :-(
I took an old 4GB Card and this one works fine. So I think my new 16 GB card (Transcend SDHC UHS-I 16 GB) is the problem...
I will try an other one these days!
05-05-2013, 05:37 PM   #4
Site Supporter




Join Date: Mar 2007
Location: Christchurch, New Zealand
Photos: Gallery
Posts: 483
QuoteOriginally posted by smurf Quote
Hi everybody!

I bought a K30 yesterday and made some testfotos today. Now I'm a little bit astonished of this phenomenon:

I take one or more pictures, wait till the cam is ready to shoot again and turn it off after a view secondes. (I did this for years with my k100d without problems and I think this is a normal situation.)
But the K30 does not store the last picture in this case (Filesize always 0 kb). I must wait a couple of seconds befor the picture ist saved and I can turn off the cam.
But this is very annoying.
The SD-Card is new, Class 10, very fast and works very well on PC and K30. So i ask myself:

Is this normal for the K30? Does an firmware update help (installed version is v1.00)? Or have you any other ideas?

Thanks and greetings from Germany,
Smurf
The file sizes of the K30 are larger than those of the K100D. Say 8MB compared to 2MB in JPG size. So you will need to wait longer.

Also consider the speed of your card. It could be slower than what the camera can write to the card. Try different cards, with different speeds, and see what happens.

Regards

Chris

05-05-2013, 09:17 PM   #5
Forum Member
wolfworx's Avatar

Join Date: Feb 2010
Location: East London
Photos: Gallery | Albums
Posts: 61
QuoteOriginally posted by smurf Quote
Hi everybody!

I bought a K30 yesterday and made some testfotos today. Now I'm a little bit astonished of this phenomenon:

I take one or more pictures, wait till the cam is ready to shoot again and turn it off after a view secondes. (I did this for years with my k100d without problems and I think this is a normal situation.)
But the K30 does not store the last picture in this case (Filesize always 0 kb). I must wait a couple of seconds befor the picture ist saved and I can turn off the cam.
But this is very annoying.
The SD-Card is new, Class 10, very fast and works very well on PC and K30. So i ask myself:

Is this normal for the K30? Does an firmware update help (installed version is v1.00)? Or have you any other ideas?

Thanks and greetings from Germany,
Smurf
Not sure why there is such a rush to switch it off Mine are 'on' almost permanently as they go to sleep after a minute or so by themselves when ignored
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
cam, k30, pentax help, picture
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5II s won't switch off logjam Troubleshooting and Beginner Help 14 09-21-2013 12:36 PM
Strange sound from K30 after continuous shooting everydaylife Pentax K-30 & K-50 5 11-16-2012 10:12 PM
Switch off AF on shutter release? Neil MacG Pentax K-01 4 10-03-2012 05:29 PM
Why my K30 cannot switch to manual mode? sjsj94 Pentax K-30 & K-50 18 09-23-2012 06:38 AM
Switch is off, but everything still on. LightMeter Pentax Medium Format 2 09-16-2011 10:01 PM



All times are GMT -7. The time now is 08:43 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top