Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-07-2013, 09:15 AM   #1
Site Supporter




Join Date: Feb 2013
Posts: 61
Tak 50 1.4 8 element - blades lag

Hi all. I am looking for some help.
I start with the lens at f16. I open two clicks then close one. And repeat this pattern all the way through the scale. Following this pattern, f11 for example, is one size when your opening to it, but bigger when you are closing down to it from one click larger. Closing from two clicks larger will return it to the right size. When you move all the way up or down the aperture scale everything moves as expected. There is no oil on the blades.

I have the elements removed and have access to the top and bottom of the aperture blades, but would rather not go into this aperture mechanism any deeper. When pushing the aperture rod the is some intermittent resistance, but if it is because of dirt, it is hidden. Any ideas how to free/clean this up intact? I might be willing to break the aperture blade mechanism down if I could see how it is done. Thanks.

05-07-2013, 10:01 AM   #2
Veteran Member




Join Date: Sep 2010
Posts: 466
QuoteOriginally posted by kevinh Quote
Hi all. I am looking for some help.
I start with the lens at f16. I open two clicks then close one. And repeat this pattern all the way through the scale. Following this pattern, f11 for example, is one size when your opening to it, but bigger when you are closing down to it from one click larger. Closing from two clicks larger will return it to the right size. When you move all the way up or down the aperture scale everything moves as expected. There is no oil on the blades.

I have the elements removed and have access to the top and bottom of the aperture blades, but would rather not go into this aperture mechanism any deeper. When pushing the aperture rod the is some intermittent resistance, but if it is because of dirt, it is hidden. Any ideas how to free/clean this up intact? I might be willing to break the aperture blade mechanism down if I could see how it is done. Thanks.
I just pulled mine out to play with it a bit and have noticed that if the A-M selector isn't all the way to M that I can get a similar behavior.
05-07-2013, 01:47 PM   #3
Veteran Member
kcobain1992's Avatar

Join Date: Dec 2010
Location: Bucharest, Romania
Photos: Gallery
Posts: 1,409
Is this the same as your issue?
https://www.pentaxforums.com/forums/maintenance-repair-articles/193521-broken...p-repairs.html
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, blades, clicks, mechanism, pattern, pentax help, scale, size
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
7 element super takumar vs 8 element 50 1,4 fikkser Pentax SLR Lens Discussion 3 07-13-2013 07:59 AM
For Sale - Sold: Super Takumar 1.4/50, 8-element version, w/ pentax filter and case grahame Sold Items 3 01-20-2013 11:04 PM
8-element Super-Tak 50/1.4 -- aperture ring stiff vonBaloney Pentax SLR Lens Discussion 10 06-09-2012 08:16 AM
Just Scored Rare 8 Element Super Tak 50mm F1.4 (I think) Colorado CJ Pentax SLR Lens Discussion 10 01-10-2012 07:03 PM
For Sale - Sold: 18-55WR, 50-200WR, FA 50/1.4, M 50/2, 28-70/4, ME, Revue 135/2.8, Tak 28/3.5 ( Cristian Sold Items 15 10-22-2011 08:18 AM



All times are GMT -7. The time now is 04:26 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top