Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-09-2013, 07:08 PM   #1
New Member
Rosenquarts's Avatar

Join Date: Jul 2013
Location: Hauraki Plains NZ
Posts: 2
P50 and 30 issues.

Hello,

I am having completely different issues with both cameras.

With the P50, when I go and take an image, The lever would not rewind the film. I think it might be the shutter?, because when we first got the camera (An old lady was wanting to sell some cameras that her husband had left her with), the shutter was out of place or something. The inside of the camera looked terrible to. I was wondering what might have caused it.

Secondly, The P30. I am unsure if this is a common problem, but It does not seem to take pictures. I loaded a film in, to test it since we got it recently, and for some reason It would only take an image every 3rd or second image. So if I took an image and flicked the lever to wind to take another image, the button will not go down. At first i thought it might just not have taken, But every time I moved the lever, It would move to the next image. So out of the 24 images I could have got, I maybe got at least 6 images or more. This would be the same or different depending on what setting the numbers would be at. This is bugging me, cause I was going to be a replacement for the P50.

Any help will do please.

Attached Images
     
07-10-2013, 03:11 PM   #2
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,862
Here is a post I made a few years ago about the problem you're having with your P30, with some photos:

https://www.pentaxforums.com/forums/pentax-film-slr-discussion/83440-p30t-kee...tml#post865348

If my camera sits for a while, it'll have that problem. I can get it to work again with some exercise and it's OK for a roll of film. So far I haven't had the problem with film loaded. I have read about using naptha as a cleaner/lubricant but haven't tried it.
07-11-2013, 01:12 AM   #3
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 32,804
It maybe time to get a wee service on these machines, to get them back to full working order.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cameras, film, image, images, lever, p50, pentax help
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k-30 AF issues szmatefy Troubleshooting and Beginner Help 5 02-03-2013 03:17 AM
Korean K-30 Focus-Peaking Test (and Overall K-30 Review) Welfl Pentax K-30 & K-50 8 08-23-2012 01:06 PM
Pentax P5/P50 Ole Pentax Film SLR Discussion 2 12-14-2010 07:24 AM
Pentax P5/P50 Halco Pentax Film SLR Discussion 6 10-04-2009 02:51 PM
Advice Needed: P50 AMBIVALENCE Pentax Film SLR Discussion 2 09-16-2009 07:38 AM



All times are GMT -7. The time now is 06:00 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top