Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-11-2013, 08:54 AM   #1
New Member




Join Date: Jul 2013
Posts: 8
K5 IIs Issue

I bought my K5 IIs one week ago, i found that whenever i take a pic, a sandglass appears, and stay at the centre of the screen for about 5 or 7 seconds to review the pic i have just taken. i used the SD card in my Canon 60D, with no issue, the picture can be displayed on the screen immediately.

At first, i thought it's recorded Pixels issue. by default, it was set to 16M. i changed it to 10M. the sandglass is still there. and then i set the JPEG Quality from 5 stars to 4 or 3 , still couldn't resolve the issue.

dose anyone who know what happen to my camera, or the Pentax just like this (takes few secons to review the pic). or i need buy new SD card with higher speed storage.

Thanks in advance

08-11-2013, 09:03 AM   #2
Site Supporter
jatrax's Avatar

Join Date: May 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 10,749
What class card do you have? Class 6 would be the minimum recommendation with class 10 better. You should also check to see if you have highlights/shadows correction on or off. That is often the cause of such delays. Typically you should be able to shoot 16mp best quality with no delay, so this is not normal for Pentax.
08-11-2013, 09:08 AM   #3
New Member




Join Date: Jun 2012
Location: Aberdeen
Posts: 6
QuoteOriginally posted by chrisan Quote
I bought my K5 IIs one week ago, i found that whenever i take a pic, a sandglass appears, and stay at the centre of the screen for about 5 or 7 seconds to review the pic i have just taken. i used the SD card in my Canon 60D, with no issue, the picture can be displayed on the screen immediately.

At first, i thought it's recorded Pixels issue. by default, it was set to 16M. i changed it to 10M. the sandglass is still there. and then i set the JPEG Quality from 5 stars to 4 or 3 , still couldn't resolve the issue.

dose anyone who know what happen to my camera, or the Pentax just like this (takes few secons to review the pic). or i need buy new SD card with higher speed storage.

Thanks in advance
Also, make sure you're not shooting in RAW+JPEG mode
08-11-2013, 09:28 AM - 1 Like   #4
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,102
If you are shooting in JPG with the lens correction enabled, it will take additional time during the save to the SD card in order to make the corrections. You can disable this through the menu.



08-11-2013, 11:31 AM - 1 Like   #5
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
Correction features are the usual culprits for the delay.

Go to the INFO screen and check that the following are set to OFF:
Highlight Correction
Shadow Correction
Distortion Correction
Lat-Chromatic-Ab Adj
08-11-2013, 02:04 PM   #6
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 7,235
jatrax, interested-observer and docrwm have given you the answer(s) above.

All probably related to in-camera PP and card speed.

Same thing will happen with K5, (and K7);
There was also another similar thread on that subject:
https://www.pentaxforums.com/forums/pentax-k-5/139036-quick-question.html

A good idea is to do a little searching via the search feature of this forum ... just a hint!
08-12-2013, 06:51 AM   #7
New Member




Join Date: Jul 2013
Posts: 8
Original Poster
thanks all, really appreciates for your great help!!! this issue has been resolved by turning off the 'Distortion Correction'.
08-12-2013, 09:55 AM   #8
Veteran Member
Docrwm's Avatar

Join Date: Sep 2010
Location: Somewhere in the Southern US
Photos: Gallery | Albums
Posts: 11,275
QuoteOriginally posted by chrisan Quote
thanks all, really appreciates for your great help!!! this issue has been resolved by turning off the 'Distortion Correction'.
Very happy that it was helpful. Enjoy your camera!

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, card, issue, k5, pentax help, photography, pic, review, screen, sd
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 IIs Battery charger Issue chrisan Troubleshooting and Beginner Help 4 08-06-2013 05:30 AM
k5 or k5 iis ejaedon Troubleshooting and Beginner Help 7 05-10-2013 10:36 AM
Freeze Issue Redux - K5 IIs JBWPhoto Pentax K-5 25 04-01-2013 01:57 PM
K5 vs. K5 II and IIs JBWPhoto Pentax K-5 15 12-31-2012 11:14 PM
Issue with K5 IIs preorder photovast Pentax K-5 11 10-29-2012 01:04 AM



All times are GMT -7. The time now is 05:03 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top