Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-22-2013, 07:58 PM   #1
Inactive Account




Join Date: Feb 2013
Photos: Gallery | Albums
Posts: 150
yongnuo 560 III with K5 IIs

Hi,

I am trying the Yongnuo 560 III with K5 IIs, on camera, it only fires in Av I am using SMC A 35-70 mm lens in the A position.
Out of camera flash fires with the pop up flash in any camera mode.
The wireless mode does not seem to work with wireless from the camera, I might have to get the wireless transmiters.
Anybody here has experienced the same with this setup?
Also tried with the MX-1 and fires in slave mode with the MX-1 pop up flash.

Thanks for your help

08-22-2013, 08:33 PM   #2
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
It only works in wireless mode with the RF-602 or RF-603 transmitters from Yongnuo. I have heard the RF-603N works great with Pentax.

The shutter speed must be 1/180 or slower for your camera to trigger the flash, this is likely why you were having problems on camera. The same limitation applies if you are using RF triggers.
08-22-2013, 09:23 PM   #3
Inactive Account




Join Date: Feb 2013
Photos: Gallery | Albums
Posts: 150
Original Poster
Thanks! I will try that, do those wireless triggers transmit TTL too or is it another model?
08-22-2013, 09:36 PM   #4
Inactive Account




Join Date: Dec 2008
Location: North Carolina
Photos: Albums
Posts: 1,720
QuoteOriginally posted by dltorre Quote
Thanks! I will try that, do those wireless triggers transmit TTL too or is it another model?
The YN-560 can't receive any TTL signals, so it doesn't matter in this case, but the RF-602 and RF603 are manual only. They don't currently make a P-TTL model for Pentax.

08-22-2013, 10:50 PM   #5
Inactive Account




Join Date: Feb 2013
Photos: Gallery | Albums
Posts: 150
Original Poster
Thanks for all the info, I did get it to work on M now lowering the shutter speed to 1/160, Thanks!
08-25-2013, 06:59 PM   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 26,187
I was just looking at the manual for this flash today and your flash is fully manual except that it supports wireless and optical trigger. There are a couple reviews of the predecessor model (560 II) here:

Yongnuo YN560II reviews - Pentax Camera Accessory Review Database

M-mode or X-mode is the way to go.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, fires, flash, iii, mode, mx-1, pentax help, pop, yongnuo
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yongnuo YN-560 III Flash 2.4GHz worth buying or not? siamthai Pentax K-5 98 04-08-2015 09:28 AM
Pentax K-5 and Yongnuo 560 III wmich Troubleshooting and Beginner Help 6 07-24-2013 12:47 PM
What's up with my new Yongnuo Speedlite YN 560-II...no hotshoe mount? Edgar_in_Indy Flashes, Lighting, and Studio 13 04-16-2013 11:49 AM
Yongnuo 560 II jeztastic Flashes, Lighting, and Studio 6 03-07-2012 04:13 PM
Yongnuo 560 with K200d iClick Pentax DSLR Discussion 2 06-17-2011 08:57 PM



All times are GMT -7. The time now is 01:42 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top